Water Pump Woes (1 Viewer)

Joined
Dec 21, 2008
Messages
92
Location
Phoenix, Arizona
I have been told that the early (Pre '68) water pumps are not available anymore and that you must now convert to, and use, a '68 to '75 pump. Thus, to replace mine, I went to the local auto parts store and got one. I installed it on my '67 FJ40. When I went to put on the water pump pulley, it was too far away from the crank and alternator pulleys. :mad: The water pump pulley groove is too close to the radiator now, does not line up with the other pulleys, which means that the "conversion" water pump has a longer neck on it. Am i correct that I will have to change the pulley too?

Any insight into this "mandatory conversion" that has generated my water pump woes?

I had to change my alternator bracket setup too :mad:, but that will be the subject of another post, so that I can put pictures in.
 
Joined
Apr 20, 2006
Messages
132
Location
Livingston, MT
I don't claim to be an authority on this, but I believe you can still get a short "neck" water pump or a long "neck", you might need the short neck. :meh:
 
Joined
Mar 10, 2007
Messages
81
Location
Montana
water pump

Looks like SOR has them..

Water Pump Kit-
Fits 1958-1967 with heater-Comes with new water pump, #054-03 radiator hose, #054-04 radiator hose, and #054-08 heater pipe-SOR recommends replacing #054-26 gasket, order separately-

:)
 

65swb45

Elder Statesman
Supporting Vendor
Joined
Apr 14, 2004
Messages
28,934
Location
818-953-9230
 
 
 
Pics? If the pump housing is aluminum, they probably sold you the wrong one. As I mentioned in one of our phone calls, I run the 68-74 pump on my 64, and there are no alignment issues.

Best

Mark A.
 
Joined
Dec 21, 2008
Messages
92
Location
Phoenix, Arizona
Looks like SOR has them..

Water Pump Kit-
Fits 1958-1967 with heater-Comes with new water pump, #054-03 radiator hose, #054-04 radiator hose, and #054-08 heater pipe-SOR recommends replacing #054-26 gasket, order separately-

:)
The SOR kit is a conversion to the '68 and up waterpump and the necessary hoses that went to it. Unfortunate for my wallet, I speak with them on a regular basis. :doh:
 
Joined
Dec 21, 2008
Messages
92
Location
Phoenix, Arizona
Pics? If the pump housing is aluminum, they probably sold you the wrong one. As I mentioned in one of our phone calls, I run the 68-74 pump on my 64, and there are no alignment issues.

Best

Mark A.
Mark, the housing is cast iron, looks identical to the one that came off of my '67(probably original), but had a longer neck (about an inch longer). I put the pulley from my 68/69 motor on it and it worked fine. Thus, it appears that when you use the 68 and up water pump, you have to use the '68 and up pulley as well. The '68 and up pulley is "dished" more than the '67 pulley by about an inch.

Mark, if you didnt have to switch pulleys, then I have no idea what the situation is. All I know is that mine is now working! :bounce:

I will post a pic or two of the current pump setup in my "saved another one" thread.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom