Ultimate Starter, EFI relay, Ford Solenoid Mod, VSS, ignition switch, NSS, fuel pump issue thread.

Joined
Mar 25, 2005
Messages
2,140
Location
Edmond, Oklahoma
Wow if that isn't a big enough thread title.
Ok guys, it's been a while since I posted a thread but here it is. It's my wife's 94 FZJ80 "Green Bean" I posted here:

Everyday I see posts about problems with no start issues, starters, EFI relays, NSS etc. and get tired of seeing them being brought up. Here are some of my attempts and solutions on what I found with our 94 which addresses these issues.

-Years back, first issue was starter wouldn't turn over. Rebuilt solenoid at least twice over a few years and seemed to work for a while. Once it failed again, I purchased a starter from Oreilly's. Also worked for a while longer but then it proceeded to not crank again.
-Added the Ford solenoid starter mod seen here:
94 delayed cranking. Starter, ignition switch, or other? - https://forum.ih8mud.com/threads/94-delayed-cranking-starter-ignition-switch-or-other.987114/
This I have done to many 80 series with great continued success and on this truck worked well for much longer.
-About 6 months ago, key wouldn't start truck so added a small discrete push push button to the Ford solenoid relay circuit and that also worked for quite a while.
-About 2 months ago truck started hiccupping on very bumpy roads (the best word I can describe it) only after about 10 to 15 minutes of driving. First 10 to 15 minutes was perfect, no hiccup as well as driving on smooth roads. Tach or speedometer was bouncing to 0 when hitting a bump which felt like transmission was shutting down. Not sure which (Tach or Speedo) because it's not my daily driver and my wife is relaying issue.
-Changed the VSS (because it's 27 years old and may be culprit) and did not resolve issue.
-Checked battery connections, fusible links, about every wire connection, relay connection and fuse to try to recreate the hiccup with no luck.
-Pulled fuel pump to carefully inspect connections and all tested out.
-Changed EFI relay and BAM that was it. Changing the EFI relay solved the bumpy road engine cut off after being warm issue. Almost all good right?
-Still have the ignition switch not starting vehicle so I changed the ignition switch. Still nothing different. Wife still had to use the button to start with the key in the On position.
-Last week wife mentioned truck wouldn't start with button so I had her try shifting to Neutral. Bingo, Truck started.
-That worked for a while, then yesterday no crank in either P or N. Luckily it was parked in my shop.
-So last night I went straight to the Neutral Safety Switch grey barrel connector and worked it over a bit and Success! Key is starting the engine again!

Anyway. Hope this helps others with similar issues. Changing EFI relay fixed bumpy road engine cutoff. NSS barrel connector rework fixed the ignition start problem.
Wasted $ was VSS replacement, ignition switch replacement, and ?able starter work. All labor was performed by me so that was just pure FUN!
 

FMC80

GOLD Star
Joined
Sep 30, 2017
Messages
1,259
Location
Beyond
S,
Thanks for the info! Glad you were able to isolate the issue and resolve it.
 

NLXTACY

Wits' End
Supporting Vendor
Joined
Dec 7, 2007
Messages
27,527
Location
Medford, OR
Website
absolute-wits-end.com
Holy cow! I have a customer JUST ask about this exact issue and making a “work around” solution. Then today I tried moving a customer’s 94 into the shop. No start. His relay was brand new but sure enough, faulty NSS. 😂
 

Users who are viewing this thread

Top Bottom