1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

turn signals going nuts

Discussion in '40- & 55-Series Tech' started by fj40_rico, Jul 18, 2005.

  1. fj40_rico

    fj40_rico

    Messages:
    200
    Likes Received:
    0
    Joined:
    Sep 11, 2003
    Location:
    Orem, UT
    I finish painting the cruiser over the weekend so I took the front end appart. when I put back together I noticed that I had a blown fuse and now my turn signals won't blink and they come one when I hit the brakes. I have checked the grounds and they are all fine. Would my problem be the turn signal relay?

    Thanks.

    - Rico.
     
  2. dgangle

    dgangle total rice SILVER Star

    Messages:
    4,002
    Likes Received:
    13
    Joined:
    Nov 24, 2004
    Location:
    Heart of Dixie
    I say it's a ground issue. When you press the brakes apparntly the turnsigs are finding a ground through the brake light circuit. Many moon ago I installed a Malottte fiberglass front end and missed a ground to the inner fender and all sorts of weird chit went on, electrically speaking of course.


    Try running a jumper from the body of the 1156 turnsig bulb to a good, known, clean ground (or - bat post) and tell us what happens.
     
  3. petescoffee

    petescoffee

    Messages:
    1,884
    Likes Received:
    41
    Joined:
    Dec 29, 2002
    Location:
    Walnut Creek, CA
    Check where the washer and nut tightedn under the body as that is the ground point. Mine had paint on it and would not ground.
     
  4. fj40_rico

    fj40_rico

    Messages:
    200
    Likes Received:
    0
    Joined:
    Sep 11, 2003
    Location:
    Orem, UT
    Well, I started to follow wires and realized the hazard switch was pulled out and that is what was causing the issue with the turn signals. But now my hazards are not working. So back to tracing stuff.

    Actually... I don't think they've ever worked.

    thanks for the help.

    - Rico.
     
  5. warpdriv

    warpdriv

    Messages:
    3,722
    Likes Received:
    224
    Joined:
    Jan 10, 2003
    Location:
    Austin, Tx
    I do not know about 73 (yours from the sig) but my 1/71 had a burnt turn signal switch that was freaking out the brake lights.

    hth,
     
  6. RUfj40crazy

    RUfj40crazy

    Messages:
    209
    Likes Received:
    0
    Joined:
    Sep 23, 2004
    Location:
    Ride in VA now in NOVA
    wiring

    Double check your wiring!!!!! My turn signal wiring was reversed on the pass. side and that fubar'd the signals and the running lights and signals on my 76'. Get out the volt meter unhook both your leads on the signals, set the turn lever and check your voltage, adjust accordingly. And always check your gounds... Happy hunting.

    Peace
    Neal