Trip meter & odometer not working on my '91

Joined
Jun 20, 2007
Messages
414
Location
Provo, Utah
 
I have a 1991 FJ80, and when I got it the trip meter and odometer did not work. Evidently they stopped working long ago, as the odometer only shows 42,000 miles. I pulled the gauge cluster to look at it and it wasn't apparent that anything was wrong. I got a drill and spun it via the mechanical cable input and the trip meter and odometer DO work that way. I am stumped. The speedometer seems to be working correctly, but neither mileage indicator will work. I would appreciate anyone who might have some input on this problem. Thanks in advance.
 
Joined
May 12, 2015
Messages
686
Location
Bakersfield, Ca
 
I know it's been a long time since you posted this. But did you ever figure this problem out ? I have the same problem. Thanks
There's a little lever that breaks from pushing the trip reset. I had to get a new(used) cluster and swap out that gauge.
The odometer can be reset to match the old one.
 
Joined
Sep 28, 2018
Messages
5
Location
Honolulu, Hawaii
I know it's been a long time since you posted this. But did you ever figure this problem out ? I have the same problem. Thanks
Sorry for the super late reply. To answer your question, No. What I did was bought a parts truck that I still can use for wheeling and just having fun. So I'm going to switch the whole unit into my Pretty FJ80 that doesn't really go off-road. The parts FJ80 getss all the action.
 
Joined
Mar 2, 2020
Messages
9
Location
Albuquerque, NM
Reviving a dead thread. I just purchased a 92 FJ80 3FE last night, “176k” but I noticed the odometer counts a mile for every few miles lol trip Meter sits at 0000, speedo doesn’t work but I knew that before purchase, PO has one ordered for me from AUS. Is switching the gauge/gauge cluster the trick to get em working again?
 
Top Bottom