Threads on Exhaust rattle and "D" light??? (1 Viewer)

Joined
Apr 18, 2005
Messages
18
Location
Seattle, WA
Ok, maybe I'm dumb with that search feature... and I know they are out ther, but I absolutely cannot find the 2 threads I so desperately need...

1) Instructions on how to fix that pesky "D" bulb burnout in my dash that seems to so often appear for us 80 owners...

2) That "at idle" exhaust rattle which is a heatshield or something I'm sure because it goes away under load (step on the gas).

Any help finding these threads would rock!

Thanks,
Justin
 
Joined
Jun 11, 2003
Messages
690
 
 
 
Not sure about the threads but the D bulb can sometimes be remedied by flicking the cluster with your finger several times. Sometimes the bulb is fine and only needs a flick or two to get working again.

The at idle rattle on my 80 was coming from the heat shield on the header pipe accessible from the passenger side front wheel well. A quick tack weld or wire should do the trick if this is your problem.

Isn't it nice to have these minute problems?
 
Joined
Aug 16, 2004
Messages
89
Location
Menlo Park, CA USA
 
CougarCruiser97 said:
Ok, maybe I'm dumb with that search feature... and I know they are out ther, but I absolutely cannot find the 2 threads I so desperately need...

1) Instructions on how to fix that pesky "D" bulb burnout in my dash that seems to so often appear for us 80 owners...

2) That "at idle" exhaust rattle which is a heatshield or something I'm sure because it goes away under load (step on the gas).

Any help finding these threads would rock!

Thanks,
Justin

1. See this thread

Call CDan, he'll get you the parts. I replaced mine without mishap similar to the way Cary described it. That being said, I had some experience in this area, I took apart my old toyota pickup cluster several times to repair several self-inflicted mishaps.

2. Check for rocks stuck between the cat and the shields, and for loose shields. Also check the little rubber exhaust mounts. My cat shields were tight with no rocks in them, but the mounts were broken. Rattled at idle, quiet under a load. Mild annoyance, but worth fixing since GF pointed it out everytime she rode/drove the 80.

CDan got me the parts I needed on this as well, knew exactly what I was talking about when I asked for the parts. A great listener, a great guy.

:cheers:

-Dog
 
Joined
Jun 13, 2005
Messages
91
Location
Salt Lake City, Utah
 
 
 
I fixed my rattling heat shield with a few hose clamps. The heat shield is rusted around the original clamp and looked like the whole thing was about to fall off.

Good luck.
 
Joined
Sep 7, 2005
Messages
267
Location
Maine
 
 
I was searching for "D" light post's also and couldn't find any. I thought maybe it was meant to go out when in drive. I kind of like it that way. One less light shining in your eyes when driving at night. I also dim all dash lights when driving at night for sharper vision.
 
Joined
Jul 14, 2003
Messages
633
Location
CHARLESTON WV
 
 
 
i too recently experienced some problems in the exhaust area.
towing the boat trailer home one saturday evening,i noticed a loud exhaust leak when i pulled away from a stoplight.luckily i was only a couple blocks from the driveway so i parked it and checked it out the next morning.

i found that the nuts had rusted off of my front o2 sensor and it had popped out,causing the leak.

a quick trip to my dealer had me a new gasket and nuts to replace the missing parts.leak fixed but while under there i noticed my front shield top half rusting and the front clamp for it gone,so those have been ordered as well,and further inspection revealed that the hanger at the rear converter connection is also rusted-gone.

according to my dealer its part of the pipe after the converter and not a bolt on so after checking into it,i bit the bullet and ordered a borla cat back system and will be installing it in a week or two(expected delivery 9/22/05)once it arrives i will see if it comes with the gasket where the pipe bolts to the rear converter because i can see i will have to cut or grind off the original bolts to that connection and if the gasket doesnt come with the borla system i will get it from the dealer and pick up the bolts etc as well(probly get some stainless stuff) to replace those as theres a decent marine supply place near the dealer and i can get some stainless bolts there.

i found a second exhuast bracket broken on my system back at the rear side of the muffler,and i had some rattle when hitting decent bumps etc,so thats why i decided to just replace the whole system as its already 9 years old and rusting

doug
 
Last edited:
Joined
Jul 24, 2005
Messages
199
Location
MA
 
 
 
I had/have a fair amount of exhaust rattle. Coming from MN, my trucks exhaust is mostly rust. When the rattle first developed, it was extremely loud at start up. Upon looking underneath, I found that all of the exhaust mounts had rusted through and that my system was held up solely by the manifold and a crossmember it was now resting on. I bought some universal exhaust mounts and remounted the system which eliminated the rattle, until about 1,000 miles later when one of those mounts broke and I got a rattle only when in reverse. I then reremounted it in a slightly different manner which solved the problem for about 500 miles, which is right now. Now I have a little rattle at low speeds going forward, but I no longer care to fix the exhaust anymore.

If none of that helps, I'm sure a big chrome exhaust tip will cure what ails your system. :)
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom