that was a nice surprise (1 Viewer)

Joined
Feb 21, 2011
Messages
117
Location
StL
When I picked up my LC I knew a couple things (horn, hvac lights, windshield washer, etc) weren't working and I wasn't too worried about them b/c it was my project and third vehicle. I got around to checking some fuses and low and behold I had a 15A out, but w/ my fuse panel door having been nicely removed by a po I wasn't sure what circuit it fed. I was hoping the horn, but I knew that a couple other things on the horn fuse worked, so that one was out. So I got off my, very comfortable, butt and picked up some fuses today... Ready for this one ...

Oh I've got a/c! It's not very cold, but by golly it's there. I knew it wasn't working when I bought it, but given the general condition of the body and that it ran, I wasn't too worried about any luxuries not working. I'm thinkin I may find some cash under the carpet now...

Maybe if I replace the wiper motor I'll somehow learn that it's actually got a 2h in it...

WW
 
Joined
Apr 14, 2010
Messages
19
Location
Omaha, NE
I would have loved to open up my hood and see a 2FE sitting there. That the motor Toyota should have built instead of the 3FE. Its much better.
On the other hand, I was no longer able to look forward to the power increase my planned 2FE swap would provide....

The sluggish nature of my LC WAS WITH the power increase.

Also the PO played funny with the coolant lines.
 
Joined
Aug 5, 2010
Messages
4,755
Location
Colorado
 
 
I was pleasantly surprised to find the A/C worked when I bought my rustbucket. The compressor is making some ugly noises now, so I don't think it'll last too long, but I was fully expecting zero functionality.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom