temperature gauge and fuel gauge spiking at the same time

Joined
Dec 3, 2005
Messages
1,143
Location
Coquitlam B.C.
recently my fuel gauge and temp gauge started spiking past the point of no return , if i shut the ignition off for a second and turn it back on it is ok but intermitantly spikes back up both gauges at the same time , pita .
 
Joined
Mar 21, 2005
Messages
1,225
Location
Central Oregon
When my fj62, (long gone now) did this, very soon after it started the alternator went out. Dunno bout the BJ set up? But you might drop by a parts store and see if you have the correct out put from your alternator..
 
Joined
Sep 16, 2006
Messages
31
Location
Christchurch New Zealand
I nearly craped my self when my hj60 did this. Simple fix though, left boot carpet, unscrew fuel sender cover, clean earth on sender and you are on your way. The temp and fuel gauge use the same earth. Hope this helps.
 
Joined
Jan 16, 2005
Messages
1,414
Location
Dana Point/San Diego CA
cruisershmoozer is correct. I had the problem, cleaned the contacts (I forget wich guage) and problem went away. It came back a few days later. I picked up a used guage, installed it, and good as new.

I have the fix pdf'd (mud thread), so if you can't find it, let me know and I'll email.
 
Joined
Feb 17, 2007
Messages
888
Location
Oregon
Very common problem, and very common thread. Pull the instrument cluster and clean the ground contacts on the back of the fuel and temp gauge. The temp gauge gets it's gnd off of the fuel gauge, but may as well do both if you're in there.
 

Users who are viewing this thread

Top Bottom