Suspension troubles (1 Viewer)

Joined
Jan 22, 2005
Messages
53
Has anybody had any front suspension problems on a 99 lx that soud similar to this? When i drive the handeling feels sloppy and at times i feel like the weels are gonna come off or something. There is a faint squealing noise coming from the passanger side that is only audible when the windows are down. I am guess that it is a ball joint or something like that but i really don't have any idea. It is not the hydraulic suspension because i just recently had all four accumulators replaced and the fluid flushed.
 
Joined
Feb 14, 2004
Messages
1,046
Location
Sandia Park, New Mexico
 
 
 
I’m no expert on hydraulics, but it seems odd to me that you had to replace the accumulators already. Also, I would think that if your system has any air in the accumulators that it would feel sloppy.
I’d look into re-bleeding the air out of your system first.
This did occur after the accumulator swap. Right?
Please include some more information like mileage etc.
Dean
 

e9999

You want to do what...?
Moderator
Joined
Sep 21, 2003
Messages
17,204
Location
US
 
 
 
would not hurt to lift the rig and try to shake the wheels to check for play!
 
Joined
Sep 25, 2004
Messages
3,499
Location
Gleneagle, CO
 
 
 
Could be a wheel bearing going out. I had a front end problem in my camry that started at 30k and turned out to be wheel bearings (similar symptoms). On the LC they are suposed to be lubed on a regular basis.
 
Last edited:
Joined
Apr 28, 2003
Messages
2,482
Location
Turquoise Trail, N NM
 
 
 
I'd do what e9999 recommended to see if your bearings are loose. They should be repacked every 30K mi or so. That said, I've gone 100K mi on a toyota truck w/o repacking the bearings, but it was driven in a dry (CA) environment. If your wheels ever get submerged, you need to repack ASAP.
 
Joined
Jan 22, 2005
Messages
53
The truck is a 99 and has 145,000 on it. I have owned since new and have maintained it throughly. The wheel bearings were repacked about 20,000 miles ago and the accumulators were done then also. I just have no clue what this could be. I am going to an independant shop tomorrow.
 
Joined
Jun 6, 2003
Messages
2,604
Location
Cuyamaca, CA and Las Vegas, NV
Does it shake at hwy speeds?

You are right to take it in for an inspection. Let us know what they think.

On the late model Tacomas and 4runners, sloppy steering is often caused by a failure of the rack and pinion bushings (which hold the r&p tight).

Pretty much any worn front suspension component could cause this. Doubt it is bearings if they were recently inspected and serviced.
 
Joined
Apr 28, 2003
Messages
2,482
Location
Turquoise Trail, N NM
 
 
 
calamaridog said:
Does it shake at hwy speeds?

[snip]

Pretty much any worn front suspension component could cause this. Doubt it is bearings if they were recently inspected and serviced.
Unless the mechanic accidentally swapped the left/right side bearings!
 

e9999

You want to do what...?
Moderator
Joined
Sep 21, 2003
Messages
17,204
Location
US
 
 
 
well, when I got my 80, it had had the front wheel bearings repacked not too long before by a Toy dealer, and when I checked, one was loose...
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom