Starting Issues on a 1996 Landcruiser, when hot weather (1 Viewer)

Joined
Feb 21, 2011
Messages
45
Hello everyone, so my landcruiser started struggling to Start on hot weather, here is a link of the issue


If someone has encountered this issue, please advice? or someone with any idea what to tackle, highly appreciate it.

thank you!
 

chap79

Wheel. Break. Fix. Repeat.
SILVER Star
Joined
Mar 20, 2009
Messages
3,036
Location
Harrisonville, MO
Starter contacts more than likely. Try whacking the starter with a big wrench or piece of pipe a couple of times. Mine used to do the same thing a few times but usually only when the weather was really hot.
 
Joined
Dec 10, 2007
Messages
7,653
Check your battery cables (good clean connections to the battery posts).
 
Last edited:
Joined
Dec 10, 2007
Messages
7,653
You may have to replace your starter. You can find a 2.0kW Denso Aftermarket starter (RockAuto) or go for a Toyota Reman'd starter. Contacts and plunger could be replaced but in this situation a new starter might be the easiest route. IMHO.
 
Last edited:
Joined
Jun 15, 2019
Messages
89
Location
Logan, Utah.
Starter contacts more than likely. Try whacking the starter with a big wrench or piece of pipe a couple of times. Mine used to do the same thing a few times but usually only when the weather was really hot.
while whacking the starter, dont forget to cuss. I've found the more I cuss during things like this the better I feel. :rofl:
 

Users who are viewing this thread

Top Bottom