Stalling issues - Will my LC ever be reliable? (1 Viewer)

Joined
Oct 5, 2019
Messages
284
Location
Georgia
Ok. I FINALLY got my fusible link and replacement junction block. Took a closer look this morning at everything and good christ, if the fusible link doesn't end up being my problem, I should've replaced and cleaned everything a while ago either way.

Is it just me or did the previous owner do some weird stuff. Everything looks straight forward in regards to replacement but that red wire doesn't have a male connector piece to go into the female end on my fusible link replacement I got from Wit's End. I'm not very knowledgable with my 80 but I'm trying to learn. What should I do here? Is there a male connector I can buy and put together? Can I just cut the red female connector from the link and connect it straight up?

Thanks a bunch.

View attachment 2402946View attachment 2402947
Trace that red wire to see where it leads. It probably is an afterthought auxillary wire going to a radio or something else. It might also be a work around wire trying to circumvent the fusible link. Match up the three wires of the fusible link to the old link. Should be two connections in the black box and the third female connector wire should snap into the male end of the harness. Anything left over is probably an extra.
 
Joined
Aug 20, 2019
Messages
43
Location
Los Angeles, CA
Yea my guess is that red wire IS the third female connector chopped up by the previous owner. I dont see a Male connector to go into the female so im assuming its that. I think someone previously cut it off.

I think I found some super duper handy pics via search. Im guessing I cut the red in the car and put on a new male housing connector to that red wire.

conect1.png
conect 2.png
FusibleLinkBatteryShot.png
 

LINUS

Waiting for the Great Pumpkin
Joined
Mar 29, 2003
Messages
5,665
Location
PNW - WA
The upside is your location - if you haven’t yet poked around the regional clubhouse section, I bet the guys there can point you towards someone who speaks 1FZ fluently & can be more precise than the “parts cannon” -mentality mechanic.
 

claiborne86

SILVER Star
Joined
Jan 27, 2020
Messages
31
Location
Goldsboro nc
So I have a 94 and it gave me hell trying to figure out what the intermittent issues were. Mine would run rough cut off stutter like hell and drove me crazy . I spent a fortune chasing wiring issues and fuel and this and that and did 02 sensors. Ended up being the brand new but cheap distributor that was on it when I bought it. I replaced with a used Toyota and been smooth ever since. Good luck man
 
Joined
Aug 20, 2019
Messages
43
Location
Los Angeles, CA
So I have a 94 and it gave me hell trying to figure out what the intermittent issues were. Mine would run rough cut off stutter like hell and drove me crazy . I spent a fortune chasing wiring issues and fuel and this and that and did 02 sensors. Ended up being the brand new but cheap distributor that was on it when I bought it. I replaced with a used Toyota and been smooth ever since. Good luck man

yea that’s on the list of to-do’s.Gonna try fusible link first. It’s looking pretty gnarly from the previous owner. I’ll go distributor next. Glad you got things to work. Gives me hope.
 

claiborne86

SILVER Star
Joined
Jan 27, 2020
Messages
31
Location
Goldsboro nc
yea that’s on the list of to-do’s.Gonna try fusible link first. It’s looking pretty gnarly from the previous owner. I’ll go distributor next. Glad you got things to work. Gives me hope.
Yeah man don’t give up you will get it. Look on the plus side when you get it you will know every inch of it. That’s what I tel myself haha.
 

Users who are viewing this thread

Top Bottom