sm420 clutch problems - smoking

This site may earn a commission from merchant affiliate
links, including eBay, Amazon, Skimlinks, and others.

FishTown

TLCA Member #29560
Joined
Jul 19, 2010
Threads
137
Messages
1,385
Location
New Braunfels, TX
For the past couple months, I've been getting smoke in the cab of my cruiser when I'm in gear. I couldn't figure the problem out for a while and posted something on here about it.

Yesterday was the first time I had driven it in about a month and it was smoking just the same. I came to a stop sign and when I went to put it in gear, it wouldn't go. I had the clutch to the floor and it wouldn't go into any of the gears. I sat and messed with it for a minute and finally got it in gear and came home.

I'm not extremely mechanically inclined, but I can do some basic fixes. Any suggestions? Should I take it to a shop? And if I do that, I'd like to have a good idea of what's going on so I can talk to the mechanic about it.

Any/all help is a appreciated.
 
Clutch not releasing all the way? Check fluid and bleed clutch cylinders perhaps.
 
The rear main seal is likely leaking oil. Once the clutch disc is fouled, you need to replace it. If you're not mechanically inclined, take it to a shop and get an estimate for a clutch replacement including pilot and throw-out bearings, flywheel resurface, new clutch and clutch cover/pressure plate and a new rear main seal. If there are _any_ leaks in the oil pan it's a great time for a new gasket there too.
 

Users who are viewing this thread

Back
Top Bottom