Rear Vent not sealing

Joined
Aug 30, 2005
Messages
522
Location
Houston, TX
My passenger side window vent isn't sealing tightly. The black screw/gromit that pulls it close is loose. Is it just a cap that pops off? Seems like it just needs to be tightened.
 

DMX84

 
 
Joined
Feb 14, 2004
Messages
1,028
Location
Sandia Park, New Mexico
Aedgington, after looking at mine, there should be a Philips screw drawing the window onto the mount/operator. It’s tight against the window on mine, but I would not give it death, as this could break the glass. You probably should use some removable Loctite 242 to prevent this form reoccurring.
 
Joined
Aug 30, 2005
Messages
522
Location
Houston, TX
how did you access the screw? from the inside or outside? i can't seem to get the inner moldig off of the assembly nor can i pop off the black cap on the outside of the glass.
 

DMX84

 
 
Joined
Feb 14, 2004
Messages
1,028
Location
Sandia Park, New Mexico
I didn’t have to do mine; I just looked at it to help you out. The black button is not a button, but the back of the bolt going through the glass with a rubber grommet. Open the window and try accessing it form the inside. If you cannot get to it from inside, then use a #2 Philips apex bit with a ratcheting screwdriver. Snap-on model R810SA works well. Sorry I didn’t look any further.
Hope this helps.
DMX
 
Joined
Aug 30, 2005
Messages
522
Location
Houston, TX
Got, thanks for the help. had to put my apex bit in a speed wrench to get it done, very small space on a 90* angle.
 
Top Bottom