radiator hose fit issue (1 Viewer)

Joined
Dec 31, 2019
Messages
233
Location
dyersburg, tn
per photo, the lower radiator hose/water pump to union pipe appears to be too long. i ordered this item from Cruiser Corps and it is labeled to fit 1968-1983. Mine is a '77. thoughts?

20200819_100017.jpg
 
Joined
Jul 6, 2020
Messages
171
Location
Poulsbo, WA
Your hose looks like it may be aftermarket. If so, it might require some trimming. An OEM hose won't require any trimming, but some aftermarket hoses do. I'm going through an entire cooling system replacement on my 79 right now. I used OEM for the top radiator hose and bypass hose but used Gates for the two large bottom hoses. I had to trim quite a bit of length off the water pump end (like about 3 inches or so) and a small amount (like 1/2 inch or so) off of the coupling (lower) end. It all fits great now. Good luck.
 
Joined
Dec 31, 2019
Messages
233
Location
dyersburg, tn
Your hose looks like it may be aftermarket. If so, it might require some trimming. An OEM hose won't require any trimming, but some aftermarket hoses do. I'm going through an entire cooling system replacement on my 79 right now. I used OEM for the top radiator hose and bypass hose but used Gates for the two large bottom hoses. I had to trim quite a bit of length off the water pump end (like about 3 inches or so) and a small amount (like 1/2 inch or so) off of the coupling (lower) end. It all fits great now. Good luck.
you're right. half my hoses are aftermarket and that is one of them. i plan to order the oem hose tomorrow. thanks for your help!
 

Users who are viewing this thread

Top Bottom