Quick Diagnosis (A/C blower)?

Discussion in '60-Series Wagons' started by jl, Jul 14, 2005.

  1. jl

    jl

    Messages:
    87
    Likes Received:
    3
    Joined:
    Jan 19, 2004
    I was driving today with the AC on, and then it stopped _blowing_ hot air. If I set the slider on 'fresh' I got cold air, but nothing when I put the slider on 'recycle'.

    Any quick ideas on why the blower might of gone out? I didn't notice anything electrical, or mechanical in terms of sounds or smells. It seemed to just stop working...
     
  2. Mike S

    Mike S

    Messages:
    2,537
    Likes Received:
    18
    Joined:
    Aug 19, 2003
    Probable that the circuit breaker tripped. Check the CB on the fuse panel and reset.

    M
     
  3. swank60

    swank60

    Messages:
    1,484
    Likes Received:
    244
    Joined:
    Aug 26, 2002
    Location:
    One of Four Presidential Flying Saucers
    Did the blower it's self stop? If the blower stopped, it could be the brushes on the blower motor. Mine fried out not long ago. Tap the bottom of the blower motor with a screw driver handle and see if it starts the motor again (if you can't hear the motor turning at all.) It may start it up and get it spinning briefly if the tapping bounce the brushes into contact with the motor.

    Also, check the fuse.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.