PS pump leak/failure

Joined
Dec 29, 2003
Messages
2,393
Location
Louisville, KY
 
Hi all. I used a 60 PS pump for my 40 PS conversion. I have never thought it was that strong to begin with. The past week I went to the trails and noticed that it was leaking right where the reserve bottle meets the bracket.

Couple of questions:

Is it worth repairing?
Is is worth rebuilding?
Does any one know how to test line pressure?

Anybody got a good used one?

Thank you.
 

PabloCruise

SILVER Star
Joined
Jun 3, 2004
Messages
19,595
Location
Northern Colorado
 
 
 
Juke,

I am getting ready to do this to my 40.

The PS pump I got looked pretty moist.

Back in the day on the LCML, someone recomended these guys:

Power Steering Systems

305-769-0869

12062 NW 27th Ave
Miami, FL 33167

I'm fixing to give them a call this week to see what they say ($ wise, warranty, etc)

I can post up the results...
 
Joined
Jun 28, 2002
Messages
2,107
Location
Colorado Springs, CO
 
 
 
 
That is an easy fix. There is an O ring between the resevoir and the bracket/pump. You can get the ring from Toyota for a couple of bucks. Or you could pull the o ring and go get a similar size. I ended up finding a rebuild kit at napa that was like $5 and had the o ring in it. Just unbolt the pully and the resevoir comes right off.
 
Joined
Jul 22, 2003
Messages
17,825
Location
Perth Western Australia
 
 
 
Jukelemon said:
Hi all. I used a 60 PS pump for my 40 PS conversion. I have never thought it was that strong to begin with. The past week I went to the trails and noticed that it was leaking right where the reserve bottle meets the bracket.

Couple of questions:

Is it worth repairing?
Is is worth rebuilding?
Does any one know how to test line pressure?

Anybody got a good used one?

Thank you.
They often leak under the reservoir from a small O ring or you can get a complete kit from Toyota.
Any hydraulic shop should be able to pressure test it to the specs in the ma
nual.
 
Joined
Dec 29, 2003
Messages
2,393
Location
Louisville, KY
 
Thanks a bunch guys. Would that O ring create pressure loss in the system to a degree that would significantly effect "feel" of the PS i.e. would it make it harder to turn? I can see how it would but want to be sure prior to tearing into it.

Thanks Pablo for the contact. I will try the O ring fix and go from there.
 
Joined
Jul 22, 2003
Messages
17,825
Location
Perth Western Australia
 
 
 
Jukelemon said:
Thanks a bunch guys. Would that O ring create pressure loss in the system to a degree that would significantly effect "feel" of the PS i.e. would it make it harder to turn? I can see how it would but want to be sure prior to tearing into it.

Thanks Pablo for the contact. I will try the O ring fix and go from there.
No ,there is no pressure in the return to the reservoir but it will stop the leak.

If your belt is slipping that will cause low pressure.

Usually low pump presure means the vanes are worn and are exceedinng their clearances.
I think there is also some valves in there that can become choked with sludge.
The power steering shop I went to recommend trying a PS additive before stripping it down to clean out the sludge
 

PabloCruise

SILVER Star
Joined
Jun 3, 2004
Messages
19,595
Location
Northern Colorado
 
 
 
Juke,

I sent my pump off for rebuild - won't know how well things worked until I complete the PS conversion on the 40, should be soon though!
 
Last edited:

PabloCruise

SILVER Star
Joined
Jun 3, 2004
Messages
19,595
Location
Northern Colorado
 
 
 
Cool - I hope this works well.

Did you talk to them? Or just send it?

I just checked my tracking #, mine should get there tomorrow...
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom