Problem cruiser / New member wont rev past 2K (1 Viewer)

Joined
Jan 31, 2009
Messages
245
Location
Acton, CA
 
 
First of all hello to everyone I am new here and new to Cruisers.
I aquired this 86 FJ60 on a trade. IT ran like crap but regardless it ran I could get it up to 55 on flat ground but when I would hit a slight grade it would drop all the way down to a crawl likt 5-10 mph. It got progressively worse. Till the point it wouldn't even idle. Checked the tank to make sure it was flowing good. Replaced fuel pump, Fuel Filter, Air Filter, Vacuum Lines, Rebuilt carb. Got carb redone from the same guys who do the Carbs for I think their name is Landcruiser specialist or Spector Off Road in Chatsworth CA.

Now with the carb redone it idles fine and still omly runs good till 2K then it falls on it's face. On any grade it does the same thing falls on its face I can run faster than it runs. LOL.

Anybody have some insight on as to what it could be. I was thinking the vacuum secondaries aren't opening Took back carb and he said carb is fine I have other issues.

One thing I did notice If I disconnect the vent tube from the back of the valve cover it idles smoother. The vent on the Valve cover Has crazy blow by, If I plug the whole it builds alot of air pressure sounds like a air hose bust on a compressor when I take my finger off.

Any help appreciated.

I'm in so cal and broke as a joke right now so I need to try and fix it myself.
 
Joined
Apr 25, 2005
Messages
586
Location
Boulder Creek, CA
 
 
 
is the timing adjusted right? Sounds like someone might have advanced the timing for high altitude and not brought it back for sea level. Same thing happened to my buddies 60. We went to Tahoe and advanced the timing for altitude and forgot to retard it later. Drove like s*** back in the bay area and most of the way there until one of remembered to fix it.
 

Spike Strip

Midnight Rider
SILVER Star
Joined
Nov 22, 2005
Messages
14,858
Location
City of Angels
 
 
 
Timing should be 7 degrees BTDC -- There will be a little "BB" in the flywheel at the correct timing mark. TDC will be a line next to the BB ... BB may be missing, so you might just have a BB-sized hole.

Timing mark access is on the bellhousing, behind a window, just above the starter. Flip the window up to see the flywheel.

Now, since you're in CA, have you had this thing smogged ? Did it pass?

Where in So. Cal. are you?
 
Joined
Jan 31, 2009
Messages
245
Location
Acton, CA
 
 
I have not smogged it. I need to get it smogged. I have a temporary permit for a couple of days to get it smogged but if I can't even get it running well then I'm SOL. I'm not really worried about smog ;) Your in the Valley as far as I know the valley is Sanfernando valley. I am in Acton about 20 minutes from there. I'm before Palmdale on the 14. This thing definately needs work. I'm going to fix it up as nice as I possibly can without breaking the bank.

I guess I'm going under to look for the BB in the flywheel.
 

Spike Strip

Midnight Rider
SILVER Star
Joined
Nov 22, 2005
Messages
14,858
Location
City of Angels
 
 
 
You see the timing from the top -- the access plate is above the starter... do a search and I know there's a pic here somewhere...

Leaning over the passenger fender, you'll see it on the flat surface of the bellhousing, next to the block - above the starter.

7 degrees BTDC at 950 rpm -- Check the timing advance, too...
 
Joined
Jan 31, 2009
Messages
245
Location
Acton, CA
 
 
thanks for all the help guys I tried everything. Didn't work. Then I just floored it and then I engaged the secondaries manually and it blew the vacuum lines off the EGR valve then it hit me it's building up pressure and screwing up the vacuum. Checked the exhaust and almost nothing coming out. Removed the catalytic converter and it runs like a champ now. Cat was completely clogged. Well at least my cruiser is timed correctly and a good tune up now. Now just ned to get a cat for it.
 

Spike Strip

Midnight Rider
SILVER Star
Joined
Nov 22, 2005
Messages
14,858
Location
City of Angels
 
 
 
yeah, me too - Would've had to replace everything else before I looked there...

Was the CAT damaged? Banged up?
 
Joined
Jan 31, 2009
Messages
245
Location
Acton, CA
 
 
Cat looked fine. It doesn't even look to old. After took it off it was night and day difference. It was the last thing on my mind.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom