popping noise during articulation

Joined
Aug 22, 2003
Messages
254
Location
Fort Collins, CO
I sometimes get a loud pop as the suspension articulates. It seems to be coming from the rear but i'm not sure. Nothing seems to be loose, all suspension bolts are tight and all bushing appear to be intact (including all control arm, panhard, swaybar and shock bushings). Shocks also appear fine. Anyone have any suggestions?
thanks, aaron
 

cruiserdan

SupportingVendor Emeritus
Moderator
Joined
Mar 27, 2003
Messages
25,269
Location
Land Cruiser Heritage Museum broom closet
Don't forget the body mounts.


Hey, look what's back :beer:
 
Joined
Jun 21, 2003
Messages
296
Location
Black Mountain, NC
Website
www.homepage.mac.com
:beer:
It was never REALLY gone. Woody just hid it from you so the rest of us could have a #6 now and then :flipoff2:

LT
8)
 
Joined
Dec 13, 2002
Messages
6,159
Location
buggerville nj
Check the busings on the swaybar - yes, I know you say they are there, but are they in the right place? I bent the pin where the sway bar goes up. Pushed the bushings out of whack and sounded like crap every time I got any action at all. 10 minute $5 fix.

Don't have a pic, but someone should be able to 'splain better.
 
Joined
Dec 13, 2002
Messages
6,159
Location
buggerville nj
[quote author=cruiserdan link=board=2;threadid=5324;start=msg41786#msg41786 date=1063730883]
Hey, look what's back :beer:[/quote]
LOL - that's why the forum was down today, so you could get your :beer: :flipoff2: :flipoff2:
 

Users who are viewing this thread

Top Bottom