Pinout for EC1 connector ? (1 Viewer)

Joined
Nov 5, 2006
Messages
1,153
I’m trying to chase down an electrical issue. I should have cleaned my engine compartment before I started so I could see wire colors !!!

I notice I have a red-white wire going in to the EC1 connector from the engine compartment, just hanging loose and not connected to anything in the engine compartment !

So far I have:

PIN. WIRE
1 Y-B
2. Y-G
3. Y
4. B-Blue
5. empty
6
7 G
8. G-blue
9. BR
10. W-B
11. G-Y
12. G-B

Does anybody have a Pinout of the EC1 connector that can tell me what/where 6 is supposed to go ?
 
Last edited:
Joined
Oct 7, 2013
Messages
401
I’m trying to chase down an electrical issue. I should have cleaned my engine compartment before I started so I could see wire colors !!!

I notice I have a red-white wire going in to the EC1 connector from the engine compartment, just hanging loose and not connected to anything in the engine compartment !

So far I have:

PIN. WIRE
1 Y-B
2. Y-G
3. Y
4. B-Blue
5. empty
6
7 G
8. G-blue
9. BR
10. W-B
11. G-Y
12. G-B

Does anybody have a Pinout of the EC1 connector that can tell me what/where 6 is supposed to go ?
What year truck? Download the ewd here and on Page 208 has the ec1 connector and wiring
 
Joined
Dec 8, 2006
Messages
10,976
Location
New Jersey
Website
www.sdsysdesign.com
EC1 pin 6 is the speed sensor that feeds the spedometer. One side is red/green (speed sensor) and the mating side is red/orange (spedometer).
The majority of the other pins is CDL and front diff logic.

This is a guess, because you didn't specify the year of the vehicle.
 
Last edited:

Users who are viewing this thread

Top Bottom