Overcoming 2LTE fuel cut limit

GTSSportCoupe

2LTE abuser
Joined
Mar 23, 2012
Messages
6,082
Location
Victoria, BC, Canada
Thanks Nick,

Out of interest do you know if the current location would alter the gauge much post filter (as it stands without the bleed off). Im away from the truck today so cant test it, but my max reading is currently 12psi with the T in that location, would this actually be higher at the manifold and ive been reading the boost wrong till now? im still going to add the bleed off and move this now, but would be interesting if this would have been putting my numbers off the last few months or not.
No, I don't think it would. Might just delay the boost reading a little bit is all.
 
Joined
Nov 10, 2018
Messages
404
Location
Conifer, Co
I have been tuning back and forth between my boost controller (after turbo) and my fuel cut (as referenced in this thread) and boost now tops out at 16 psi. The curiosity to me is that I have slowly tightened down the fuel cut bleed valve so that it is all the way tightened (which should let the MAP sensor see all boost and not bleed any boost off), yet I get no fuel shut off from the engine. Since the MAP should cut off fuel if it sees sustained 16 psi of boost, should I assume that my MAP sensor needs replacing?
 
Joined
Mar 28, 2015
Messages
165
Location
Chilliwack, BC, Canada
I have been tuning back and forth between my boost controller (after turbo) and my fuel cut (as referenced in this thread) and boost now tops out at 16 psi. The curiosity to me is that I have slowly tightened down the fuel cut bleed valve so that it is all the way tightened (which should let the MAP sensor see all boost and not bleed any boost off), yet I get no fuel shut off from the engine. Since the MAP should cut off fuel if it sees sustained 16 psi of boost, should I assume that my MAP sensor needs replacing?
Try disconnecting the air bleed off first, as I found with the screw is all the way down (tight) it still bleeds off air.
 
Joined
Mar 28, 2015
Messages
165
Location
Chilliwack, BC, Canada
I had a weird thing happen the other day while drivin. I'm about to get on the freeway and my boost spiked up waaay past 20 psi and my truck had an insane amount of power for about 1 full second until I let off the gas. Then I pressed the pedal down again and it went way past 20psi again with lots of power, almost like the waste gate had seized shut. I feathered the throttle to get the truck to drive normally until I was on the freeway then the truck started to run normal again and hasn't done it since. Any ideas guys what happened?
 
Joined
Nov 10, 2018
Messages
404
Location
Conifer, Co
Try disconnecting the air bleed off first, as I found with the screw is all the way down (tight) it still bleeds off air.
i haven’t thought to test that....
So you are saying that even with it all the way tightened down, I might still be bleeding off some boost? Interesting..... thanks.
 

GTSSportCoupe

2LTE abuser
Joined
Mar 23, 2012
Messages
6,082
Location
Victoria, BC, Canada
I had a weird thing happen the other day while drivin. I'm about to get on the freeway and my boost spiked up waaay past 20 psi and my truck had an insane amount of power for about 1 full second until I let off the gas. Then I pressed the pedal down again and it went way past 20psi again with lots of power, almost like the waste gate had seized shut. I feathered the throttle to get the truck to drive normally until I was on the freeway then the truck started to run normal again and hasn't done it since. Any ideas guys what happened?
I think you're too close to run-away on the spill valve. Turn it back out an 1/8th turn or so. Although maybe you're onto something there... 2LTE TURBO MODE!!!!!! :lol:
 
Joined
Mar 28, 2015
Messages
165
Location
Chilliwack, BC, Canada
I haven't adjusted it for almost 3000kms, and this happened once and hasn't happend again and I've driven 500kms since.... I've also had the spill valve adjusted 1/4 more then it is now and it drove fine then also....
 

GTSSportCoupe

2LTE abuser
Joined
Mar 23, 2012
Messages
6,082
Location
Victoria, BC, Canada
I haven't adjusted it for almost 3000kms, and this happened once and hasn't happend again and I've driven 500kms since.... I've also had the spill valve adjusted 1/4 more then it is now and it drove fine then also....
Well, I must say I have no other ideas. But if you could make that happen on demand, I'd be interested to know how! :D
 

GTSSportCoupe

2LTE abuser
Joined
Mar 23, 2012
Messages
6,082
Location
Victoria, BC, Canada
could it just be a case of the boost tap failing and creating a boost spike? is it a cheaper tap?
But it would make the computer think the boost is too high, in which case it would cut the fuel?

No matter what I've done on my motor I've never been able to get enough fuel for more than 20psi.... (it takes lots of fuel to spin the turbo that fast).
 
Joined
Nov 20, 2018
Messages
43
Location
New Zealand
Also with fuel up just over half a turn and the bleed off in I’m getting 13-14 psi (was 12 before) will turning the bleed off in increase boost further by altering what the map sensor reads? Or better to just play with the boost tap?
 
Last edited:
Top Bottom