1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

OME problem

Discussion in '80-Series Tech' started by apcoleman, Jul 17, 2005.

  1. apcoleman

    apcoleman

    Messages:
    386
    Likes Received:
    0
    Joined:
    Apr 12, 2005
    Location:
    Fairfax, VA
    So I was under the cruiser the other day and I look back at my driver side rear shock and my jaw dropped. I could believe what I saw. The lower bushing was trash. I have had the lift on for about a year and a half and I checked all the others and they were fine. I ordered a new OME bushing but until then I am using the bushing that came with the stock shocks which were fine. I guess I am asking has anyone seen this happen before and what would have caused this? Thanks
    bushing1.jpg bushing2.jpg
     
  2. concretejungle

    concretejungle SILVER Star

    Messages:
    9,515
    Likes Received:
    742
    Joined:
    Oct 27, 2003
    Location:
    North Cadillac
    hmmmmmm......i'm checking mine too! I've had my lift for about 2 years. I may go to bilstein shocks next time around.
     
  3. Kalawang

    Kalawang

    Messages:
    1,099
    Likes Received:
    3
    Joined:
    Jan 25, 2005
    Location:
    Philippines
    I can only guess that they did not fit the bolts or the mountings. Damage like that comes from movement.


    Kalawang
     
  4. macneill

    macneill Rollin’ on 33s

    Messages:
    4,062
    Likes Received:
    6
    Joined:
    Jun 2, 2004
    Location:
    Port Washington, NY / Edgartown, MA
    Damn, that sucks.

    Did you put that lift on?
     
  5. Harridig

    Harridig

    Messages:
    106
    Likes Received:
    0
    Joined:
    Jul 14, 2004
    Location:
    Pullman, WA
    Just checked mine - No issues here. Thanks for the warning.

    Dang, that sucks!!!

    Derek
     
  6. apcoleman

    apcoleman

    Messages:
    386
    Likes Received:
    0
    Joined:
    Apr 12, 2005
    Location:
    Fairfax, VA
    I didn't have time to put it on myself so I had it installed by a local shop that has done work on my parents cars for a long time. They take their LX and everything else there and have never had a problem before. I wonder if I just got a bad bushing?
     
  7. cruiserdan

    cruiserdan SupportingVendor Emeritus Moderator

    Messages:
    21,973
    Likes Received:
    5,736
    Joined:
    Mar 27, 2003
    Location:
    Land Cruiser Heritage Museum broom closet
    That is consistant with a loose mount.