OME install, HELP (1 Viewer)

Joined
Dec 11, 2006
Messages
94
Location
Tucson
I know it is simple and straightforward, but I'm stuck with my OME install. :flipoff2: Got the rear done no problem, but can't get the front done .... got the DS spring out, but absolutely cannot get the OME in.:doh:

Anybody in Tucson able to help? I'll buy you a case of beer, or cash, to help a newbie out. Needing to finish it today or tomorrow (Monday or Tuesday) My phone is 3six zero- 14eighty if anybody is willing and able.

I've done this on several other vehicles, but maybe I've just gotten too old and feeble to get the leverage I need ... That and working in a dirt driveway absolutely sucks. I can't drive it now because the spring is out. Aaaaaargh.

Thanks!

Jeff
 
Joined
Mar 7, 2011
Messages
80
 
Did Im assuming you disconnected the shocks.... If you have a bottle jack, put it in between the axle and the frame. Or go to the auto parts store and rent a spring compressor. Either way its easier than fighting with it.
 
Joined
Jul 20, 2004
Messages
24,774
Location
Chandler, AZ
 
 
X2 on the shocks, also the sway bar needs to be disconnected and depending on the spring the brake line hard mounts. Then stand on the hub, I have successfully at installed J springs with 1.5" spacers using this method without a compressor.
 
Joined
Dec 11, 2006
Messages
94
Location
Tucson
Sway bar off, shock disconnected ... Didn't think about the bottle jack, I will go give that a try. Thanks!
 

LandCruiserPhil

Peter Pan Syndrome
Supporting Vendor
Joined
Mar 10, 2004
Messages
24,875
Location
Scottsdale Arizona
 
 
 
Sway bar off, shock disconnected ... Didn't think about the bottle jack, I will go give that a try. Thanks!
Try loosening the bolts on both ends of the panhard or removing one end. If you do make sure you tighten them when you are sitting on the ground at ride height.
 
Joined
Dec 11, 2006
Messages
94
Location
Tucson
Ok, one more question. Do you folks run with or without sway bars? This is my primary transportation and I don't see dirt as often as I would like. occasionally pull a pop-up trailer ...
 
Joined
Dec 11, 2006
Messages
94
Location
Tucson
Ok, it is done. I needed to drop both sides of the axle. Guess I am too used to IFS. Truck looks good, can't wait to hit a trail. I do still have the steering dampener and castor correction to put in.

Thanks for tolerating my stupidity and offering suggestions.
 
Joined
May 18, 2008
Messages
982
Location
Tucson, AZ
 
 
Ok, one more question. Do you folks run with or without sway bars? This is my primary transportation and I don't see dirt as often as I would like. occasionally pull a pop-up trailer ...
Im in the "with crowd" but the mounts/links need to be lengthen to accommodate the lift.
I extended mine and still managed to rip one of the mounts off. Been without for a long time now and don't really miss it. I don't think it makes a ton of difference either way, but I'm sure someone will disagree with me.:meh:
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom