oil pressure

  • Thread starter thorvald
  • Start date
  • Watchers 0
thorvald

thorvald

.......
Joined
Aug 18, 2002
Messages
1,569
Location
on the ice, wyoming
Website
www.pointyhatdesigns.com
whats the normal range for oil pressure in an 80? and how high would too high be for oil pressure? would it indicate a problem and if so would there be many possible culprits?
my 40 and 80 tend to sit a little over the first mark line.
the 60 I bought recently was sitting there until a few days ago when it shot up to between barely under the last mark and over the last mark. Ill be changing the oil shortly in it, wonder if old oil would cause it?
anything to worry about?
 
C

cary

Joined
May 7, 2003
Messages
3,165
It sounds like the oil filter is plugged. I would change the oil and filter and see what happens.


Cary
 
S

Seminole

Joined
Mar 28, 2003
Messages
106
Might not be a PROBLEM, per se. Check the oil pressure sending unit, they are not that expensive (20-30 US). You might not have to change it, clean it or at least the connectors. Mine was shot, replaced and now reading normal.Cheaper than an oil pump or rebuild.
 
landtank

landtank

Supporting Vendor
SILVER Star
Joined
Mar 27, 2003
Messages
20,303
Location
Groveland MA
Website
landtankproducts.com
If I recall correctly there is a known problem in the 60s where the voltage to the guages can fluctuate giving false readings. It's been a while so I can't recall the particulars but remember it being common.

If I understand you the pressure is reading high and that wouldn't be a clogged filter as the sending unit is after the filter and a clogged one would produce a low reading.
 
B

BMT

Joined
Apr 1, 2003
Messages
324
What about the oil pressure in an FZJ80? I run Valvoline Max Life and the K&N oil filter. My pressure sits up at the last hash mark before the "H" but under certian conditions it will go to just below the "H" mark.
 
wob

wob

Joined
Feb 28, 2003
Messages
2,597
Location
SC
Mine sits a little above the 1/4 mark at idle, and goes to the 3/4 mark above about 2000 rpm's. &nbsp:Do I have a problem that I need to address?
 
C

cary

Joined
May 7, 2003
Messages
3,165
BMT,

Your pressure seem a bit high, what weight oil are you using? Maybe its the filter?

WOB,

Your right about where you should be.
 

Similar threads

Snyper2384
Replies
13
Views
467
Snyper2384
Snyper2384
totallyatoyota
  • Question
Replies
7
Views
345
totallyatoyota
totallyatoyota
9
Replies
7
Views
354
Nemesis1207
N
J
Replies
15
Views
302
mudgudgeon
mudgudgeon

Users who are viewing this thread

Top Bottom