oil pressure guage

  • Thread starter mwalls54
  • Start date
  • Watchers 0
mwalls54

mwalls54

Cruiser Nutjob
SILVER Star
Joined
Dec 4, 2003
Messages
2,677
Location
Roanoke, VA
I rewired my 74 fj40 and now the oil pressure guage isn't working. i have a new pressure switch too. dont know whats up with it. any ideas?
 
Landpimp

Landpimp

Joined
Mar 14, 2003
Messages
16,102
Location
Gig Harbor WA
its pretty easy to fry the guage itself, I burned up one, all I did was cut the stupid wire(when the key was on....doh!) with a pair of snips, after that the guage was WAY off, swaped in another and all was fine.

not sure if thats it or not but seeing how you just rewired it could be.
 
Mike S

Mike S

Joined
Aug 19, 2003
Messages
2,534
Website
www.autohomeus.com
It is easy to out the wire on the wrong contact point and fry the gauge. I had this problem from the PO or his mechanic, and the gauge was constantly over the top. Put in a new gauge, and set it up on the right contact and it works fine now.
 
mwalls54

mwalls54

Cruiser Nutjob
SILVER Star
Joined
Dec 4, 2003
Messages
2,677
Location
Roanoke, VA
ok i will check it out over the weekend. how will i know if its on the right contact? i have a diagram but its not the best. does a wire go from the guage cluster to the switch?
 

Similar threads

Crinkler
Replies
7
Views
229
Crinkler
Crinkler
rstoddard
Replies
3
Views
175
rstoddard
rstoddard
MarzBj42LX
Replies
8
Views
328
-MaTTi-
-MaTTi-
E
Replies
2
Views
331
ErfanFj45
E

Users who are viewing this thread

Top Bottom