Oil Leaking in Parking Brake (after replacing Speedometer Gear)

Joined
Jan 1, 2011
Messages
234
Location
Tempe, Arizona
@65swb45 @orangefj45

Is there any explanation for oil leaking from the rear brake other than from the rear seal of the Transfer? I recently rebuilt/replaced the Speedometer gear and o-rings, which is the only other thing that I can think of that might explain why I suddenly have oil dripping out the Parking Brake. The only other explanation seems to me is that the rear transfer seals are leaking, but that can't be because Mark just rebuilt the TC and put double seals in..... correct Mark?



1652898148993.png









1652898005198.png
 
Joined
Sep 20, 2004
Messages
3,064
Location
here
Is it possible that bits got in there when replacing speedo gear or from previous bad speedo gear and roasted the new double seal ? Is it leaking down backing plate or between drum & drive shaft flange and running down outside of drum ?
Curious, Mark would have noticed and replaced a bad speedo drive so having a rebuilt case and the speedo goes bad shortly after could happen but one would assume the condition of speedo drive was checked upon reassembly, describe the speedo gear damage and did it happen after rebuild ?
 
Joined
Jan 1, 2011
Messages
234
Location
Tempe, Arizona
Well, first, the oil is leaking from the bottom of the brake drum. I can’t tell where it is coming from without removing the brake drum, which I can’t do without dropping the engine due to my clearance problem. So it’s not a trivial problem to resolve.

As far as the Speedometer goes, i agree that it probably should have been renewed with new o-rings at the time of the rebuild, but since I didn’t specify that, it wasn’t done. It was leaking right off. I had to drain the oil and pull the old gear, which wasn’t any big problem and I bought a new kit from Toyota and put a new gear in with new o-rings. I don’t know how anything could have gotten into the hub and damaged the seals. The whole replacement seemed quite easy and no issues getting the gear back in.

My only thought was some oil might have leaked through when I pulled it. That’s all I can think of that could have happened.
 
Joined
Jan 1, 2011
Messages
234
Location
Tempe, Arizona
I put some RTV or similar on the splines of the output shaft and brake drum before sliding the drum on...

I don’t “think” it’s coming out of the splines. I was told by Mark that if I sealed the washer at the end of the shaft, it would prevent oil leaking from from the splines. I had that leak before. That is what I did. It was my understanding from Mark that the oil can’t get into the parking brake drum from the splines through the back side of the drum. If it can (can anyone verify?) then it’s possible that is where the oil is coming from. It can also be coming out of the seals.
 

orangefj45

Supporting Vendor
Joined
Mar 14, 2003
Messages
17,885
Location
norcal
I just read thru this thread fairly quickly.

Am I correct in understanding that the Tcase was rebuilt?
If so, then the speedo o-rings ( BOTH !!!!!!! ) should have Bern replaced at that time and they are included in every type of rebuild kit I’ve ever come across.

Yes, you should always apply a small snaking of silicone to the splines before installing the drum.

Your leak appears to be stemming from an issue at the rear output seal of the Tcase or at the seal surface on the drum.
How’s the seal surface? Any grooves or putting?

You’re going to have to pull the drum to fix this …..

I’d highly recommend one of our dual-seal rear extension housing kits to correct the issue.

Happy to help.

Georg @ Valley Hybrids @ Cruiser Brothers
Shop 209-475-8808
Sales@valleyhybrids.com
 
Joined
Jan 1, 2011
Messages
234
Location
Tempe, Arizona
Georg, I really appreciate your input. Yes, it seems to me that renewing the o-rings on the Speedo would have been a SOP, but it wasn’t done. At this point, I either lower the rear of the engine, or relocate the crossmember, to pull the drum.

Since I was able to find a pre-cut crossmember kit that locates in the rear (in that location I discussed with you before), I will call the Fabricator you recommended to me about welding the new crossmember in, then I will have the existing crossmember removed. I think that is the better long-term solution. Once that is done, I’ll pull the drum and do what I can to inspect the seals and give you a call about the “dual-seal rear extension housing kit.”

Thanks for your help!!!!
 

hobbes

SILVER Star
Joined
Feb 2, 2002
Messages
1,120
Location
SWFL
Joined
Jan 1, 2011
Messages
234
Location
Tempe, Arizona
The preload was already set (presumably) when the gentleman that rebuilt the TC installed the Hub and set the preload on the bearings. I think that is the preload you are referring to.

From my understanding of the procedure, that is a different preload setting from the preload on the drum brake stake nut.

All I did (after installing the rebuilt TC) was bolt the brake backing plate to the hub, put on the brake shoes, springs, etc., hook up the brake cable, push the drum on, and torque the nut, washer and shim.

The speedo cable started leaking right away, leading me to remove the gear and replace the o-rings and gear using the Toyota kit. I reviewed Coolerman’s page and the Mud FAQ on the subject for guidance.
 
Joined
Jan 1, 2011
Messages
234
Location
Tempe, Arizona
Georg, I really appreciate your input. Yes, it seems to me that renewing the o-rings on the Speedo would have been a SOP, but it wasn’t done. At this point, I either lower the rear of the engine, or relocate the crossmember, to pull the drum.

Since I was able to find a pre-cut crossmember kit that locates in the rear (in that location I discussed with you before), I will call the Fabricator you recommended to me about welding the new crossmember in, then I will have the existing crossmember removed. I think that is the better long-term solution. Once that is done, I’ll pull the drum and do what I can to inspect the seals and give you a call about the “dual-seal rear extension housing kit.”

Thanks for your help!!!!

@orangefj45

Georg, I’m scheduling with Campbell Enterprises to have them install a new crossmember and cut out the Toyota crossmember so I can access the Parking Brake. I’ve spent the last few weeks rebuilding the front disc brakes, do that has been a pacing item. I took it out today after the rebuild (drove a couple blocks) and oil was coming out the brake again. The weird thing is, it’s dark, dirty oil, whereas the oil in the transfer is new, clean fluid. I cleaned the entire brake, and shaft, so I don’t understand where that dirty oil is coming from. It’s almost like Mark (the guy in Burbank that rebuilt the TC) didn’t clean anything when he rebuilt the TC, or at least he didn’t clean the bearing retainer. Where else could the dirt come from?

The problem is, I have no recourse with Mark. He is not a legitimate business person who stands behinds his work,l (IMO) and he is extremely difficult to deal with, especially as I am in Arizona. I’m not going to pull the TC and take it back to him, so I’m basically screwed.

Let me know if you have any thoughts about what might be going on, otherwise I’ll contact you again when I get the crossmember moved and the Parking Brake off so I can get in there and try and see what is going on.
 
Joined
Jan 1, 2011
Messages
234
Location
Tempe, Arizona
@orangefj45
You Wrote:

[Yes, you should always apply a small snaking of silicone to the splines before installing the drum.

Your leak appears to be stemming from an issue at the rear output seal of the Tcase or at the seal surface on the drum.
How’s the seal surface? Any grooves

REPLY:

I finally got the Crossmember relocated and the original removed allowing me to pull the parking brake drum. Even before this I noticed that the only leakage was clean oil, so it seemed to be coming from the seal, but after pulling the drum and getting more oil, it’s impossible to tell where exactly it was coming from.

I haven’t been able to get a good look at the seals yet because I need to get the brake shoes out so I can get a better view, and clean things up I may have to pull the back plate too. What I could see looked okay. I didn’t see any obvious tears or issues.

As far as the Drum seal surface goes (photos below) there are wear marks but no deep grooves I can feel. There is a scratch on the surface. Not sure how else to check it.

You recommended a “dual-seal rear extension housing kit”to correct the issue. What is that?

Would that Kit replace the Hub Retainer housing I already have with the double seal (that Mark, the MUD guy in Burbank installed)? Shouldn’t that double seal do the same thing as your kit?

Appreciate your thoughts/reply.

Ron


65DAA80E-6AEE-4761-B3E4-C4D25B4F2CBD.jpeg
EEA49365-5306-4968-9589-756B14CB342A.jpeg
1A2E493D-A2CE-43FC-89B4-461336720376.jpeg
 
Joined
Jan 1, 2011
Messages
234
Location
Tempe, Arizona
Isn’t the double seal supposed to address any groove wear by putting a second seal over a virgin part of the drum flange?
@Raisehell

Sometimes they do sometimes they dont . Only 3 things that can make it leak there cracked case, bad seal, grooved drum

I posted some photos above of the Drum flange the seal rides on. It’s worn but I don’t feel a groove. What is the story on the “Sleeve from O’Reilly’s”? How does that work? Is that something that fits over the flange for the seal to ride on? Do you have a PN? Is this a good solution if the seal is good?
 
Joined
Mar 11, 2020
Messages
293
Location
SF Bay Area, Ca-NorCal
@Raisehell



I posted some photos above of the Drum flange the seal rides on. It’s worn but I don’t feel a groove. What is the story on the “Sleeve from O’Reilly’s”? How does that work? Is that something that fits over the flange for the seal to ride on? Do you have a PN? Is this a good solution if the seal is good?
The speedy/readi-sleeve pn 99177 slides over the shaft covering any imperfection giving the seals a clean surface to ride on. (remove the flange after installing). @orangefj45 's kit is a great product. He also includes 4 replacement allen heads to replace the 4 bolts on the backing plate which help with ease of maintenance in the future. It sounds like you have a double seal kit from @65swb45 already? You just need the paper gasket 494122-auto store and I would replace the 4 bolts mentioned (8x1.25 14mm length if I recall-hardware store then reseal the splines as mentioned.

Here is another helpful link to see the readi-sleeve

Speedo housing sealant? - https://forum.ih8mud.com/threads/speedo-housing-sealant.1285713/
 
Last edited:

Users who are viewing this thread

Top Bottom