occasional clicking sound from rear suspension

Joined
Jan 7, 2010
Messages
510
Does anyone know what else could be causing an occasional "clicking or a tick" sound from the rear suspension? I've had the OME shocks for couple years now no issues, few months ago got their springs also put on the back, obvious clicking sounds happened each time when I went over parking lot bumps, got the bushings and links replaced, that took care of the sound. But recently I started noticing similar but much more faint and not often, maybe 1/4 of the time, you almost have to try to hear it. Is there any other bushings or dampeners that I should have looked at or something lose? I'm not familiar with all of the rear suspension components, just wondering anything else related that's causing the infrequent clicking sound.
 

CloudCity

LuxCruisers
Joined
Jun 26, 2018
Messages
875
Location
Portland, OR
Website
www.luxcruisers.com
I think it's probably your emergency brake freezing up and clattering a bit, be sure it's all working properly. I had the same and chased it forever before working manually with my hand under the truck freed it up. Its a self-adjusting system so long as it's free to move and not binding up.
 
Joined
Jan 7, 2010
Messages
510
I will have to take another look, not sure if it is related to emergency brake. Definitely it is coming from the back, and only when the rear goes over a bump, but not each time either, very strange.
 
Joined
Dec 23, 2015
Messages
187
Location
Los Angeles, California
Website
charlesandhudson.com
I will have to take another look, not sure if it is related to emergency brake. Definitely it is coming from the back, and only when the rear goes over a bump, but not each time either, very strange.

I've got the same issue after installing new Ironman suspension, FCP and rear springs and torsion bars. A Clicky sound. Everything looks solid and I've done some wheeling with no issues.
 

Users who are viewing this thread

Top Bottom