New Member New fj60

Joined
Jun 4, 2011
Messages
340
Location
Logan, Utah
No long ago I found the fj60 and fell in love with the looks. Well yesterday I bought an 84 fj60 with 280k. Some rust...rot on the rear wheel wells but I only paid $800. Leaking oil but runs and even drove me home. I have been going through all the systems to make sure maintenance is up to date.

I am getting some new tires so it can pass inspection as this will be my daily driver. Anyway wanted to say thanks to all the members of this forum there is so much info!

If anyone could point me somewhere to get a cheap set of stock rear leaf springs I would appreciate it mine are shot maybe used as I don't have much money to put it in. Also need a Fuel sending unit.

Will try to load some pictures up.
 
Joined
Dec 18, 2010
Messages
260
Location
FT. MYERS FLA
welcome to the madness

i also drive a 1984 fj60 i have had mine 1.5 years and have never regreted it for a second welcome to the addiction. try looking in the classified section for your rear springs.
Classifieds i look forward to pictures its always nice to see new members. btw 2f's dont leak they mark their territory. :flipoff2: official mud salute
 
Joined
Jun 4, 2011
Messages
1,190
Location
NYC
I just got an 83 FJ60 a few weeks ago and I am definitely addicted. My mechanic said the mechanics are almost perfect. Needs a carburetor, speedo cable, a little EGR work and she will run like a beast. It was in storage a while before the previous owner bought it so it only has about 110K. Got some rot on the body but it still looks cool. No idea how much that body work will cost but that will be a bit down the road. I've done tons of research online and I can tell you that this is the best place to find out whatever you need. You guys are the best.
 
Joined
Oct 30, 2007
Messages
9,940
Location
Plano texas
Welcome! Short on funds is not an uncommon problem. Id get yours re-arched and it will last for a few years, buying used you would probably end up with no better than what you have. MIke
 
Joined
Dec 12, 2006
Messages
3,297
Location
7400', central NM
welcome. you got a sweet deal, as I sold my first saggin wagon @285k w/ small rust for $1500. which promptly got flipped into lifting my current 60. it is an addiction.


looking forward to pix!
 
Joined
Jun 4, 2011
Messages
340
Location
Logan, Utah
Here are some pictures FrontEnd | Flickr - Photo Sharing!

Yes it is missing a driver side door handle door works fine PO said it crack around the pin. Going to make a trip to the pick a part and see if I can find one. Not sure how many fj60 make it to the pick a part.

3 tires are bald one is brand new it is a Nexan Rodian AT II. I have never heard of these but I am considering getting 3 more to match just to save some cash. While this is going to be my DD I only have a 3 mile drive to work so getting lots of miles out of the tires is not that critical.
 
Joined
Jun 4, 2011
Messages
340
Location
Logan, Utah
While going through everything I found that the fuel sending unit is not sending or that's my assumption. gas gauge is not working and it looks like the sending unit has been "worked on" someone tried to do a solder fix. Some bad news I tried to remove the screws holding the sending unit in but they had rusted so when I turn the screw driver it striped them out.
 
Joined
Jan 3, 2011
Messages
494
Location
Westchester County, NY
Try a small socket wrench head on those sending unit screws. I ran into the same problem with the fuel pump screws and it turns out they were hex headed as well as philips head. A small socket head screw driver got them off after I cleaned them up with a wire brush and put some PB blaster on 'em. Maybe......
 
Joined
Jun 4, 2011
Messages
340
Location
Logan, Utah
Good news I was able to get the fuel sending unit working one of the terminals was rusted and I cleaned off the rust and everything is good!

I got some new tires today and discovered that my spark plugs and wires are shot. One of the wires was corroded and not making a connection. Went to Checker and had to order the parts in as no one in town had them.

More pictures of the interior coming.
 
Joined
Jun 4, 2011
Messages
340
Location
Logan, Utah
Installed new spark plugs and wires today. Also fixed the horn it was working but only in certain positions. Turns out the plunger was note making contact with the ring at the points that is screwed in. I was able to bend the brass out.

Found a local guy parting out an 83 cruiser so I am going tomorrow to get a driver door handle and mirrors for 30 bucks!
 

Users who are viewing this thread

Top Bottom