New cruiser in the stable (1 Viewer)

Joined
Nov 11, 2008
Messages
1,587
Location
Anniston, AL
I finally bit the built and bought one. I've wanted one since I was 5 or 6 when my dad would always tell me stories about his 85 that he bought new. I just thought they were the coolest looking rig, but decided that it was not a good option for a daily driver so I bought a 80 a few years back.

Fast forward to last week. A good opportunity came up where a family friend offered to sell me his 84 that he has had since 90 and I jumped on it.

Its got 155k miles and is in fair condition. Runs decent, stops decent, steers horribly, is slow as hell, and I love it for some reason.

2011-05-26_12-36-45_661.jpg

2011-05-26_15-18-58_594.jpg


I'll dig up some old pictures of my fathers 60 and take some better ones of my 84.


So here comes the questions.
-I know they are slow, real slow and don't expect it to be fast, but what are we talking a good 0-60 time is? I'm assuming it needs some tuning on the carb and timing.
-The dash lights work intermediately. You turn the lights on and get no dash lights then they randomly come on and will work fine until you turn the lights off. Then its back to nothing till they randomly come back on again. Simple fix?
-How do you make the headlamp washers work? I have the owners manual but didn't see anything about it in it.

I'll have some more questions as I dig into the turd some more.
:cheers:
 
Joined
Dec 14, 2005
Messages
1,512
Location
colorado
slow? is it diesel? if not, then its not slow..diesel is slooow like mine ;)

BTW, how much rust inside the frame?
 
Joined
Nov 11, 2008
Messages
1,587
Location
Anniston, AL
ha, its a 2f.

No rust. Only surface rust right behind the rear bumper. Its lived in Alabama all its life.

I've been searching on de-smoging it but have yet to find a thread with working images.
 
Joined
Oct 31, 2010
Messages
321
Location
Boulder,CO
"Runs decent, stops decent, steers horribly, is slow as hell, and I [COLOR=#00C800 ! important][FONT=inherit ! important][COLOR=#00C800 ! important][FONT=inherit ! important]love[/FONT][/FONT][/COLOR][/COLOR] it for some reason."
X2 kind of strange isn't it? I love how people are always clamoring to pass me in traffic, just to be sitting next to me at the next traffic light.

Mine is pretty underpowered as well, although it sounds like I need to do a valve adjust and timing before completely claiming this...

I havc loved the 60 series since my uncle got one when I was about 8. Finally got one at 33... only took a 1/4 century to get my dream car, now maybe a few years to fix all the quirks? Would love turbo diesel, but that would be mucho $$$ and time.

Welcome to the affliction! What's next? OME? sliders? have fun...
 
Joined
May 31, 2008
Messages
3,528
Location
the NJ word..
lndcruz,
You have any info on those rims? I really like them. They look a bit wider than stock FJ40 wheels? :hmm:
I'm in the market for a set of OEM steelies and am trying to nail down the right ones.

2011-05-26_12-36-45_661.jpg
 
Joined
Nov 11, 2008
Messages
1,587
Location
Anniston, AL
The wheels are off a trailer. That's about all the information I have about them. I have to give them back to the po(came with oem wheels), when I take them off I can take a few measurements.
 
Joined
Sep 14, 2009
Messages
2,737
Location
Medford, Oregon.
Wheels off a trailer?? That's a new one! lol. Most trailer wheels aren't rated too high, I'd for sure give them a close look-see. Nice cruiser. Be patient and get a 2nd job so you can "fix things" . ;)
 
Joined
Nov 11, 2008
Messages
1,587
Location
Anniston, AL
Only newer image I have
IMG_0331.jpg


After almost 200 miles I've noticed the whole exhaust is trash. The manifold is leaking, muffler leaking, and the tail pipe is rusty. Is the MAF 6 to 1 still a good header to buy?
 

Ducks

SILVER Star
Joined
Apr 5, 2006
Messages
1,896
Location
Oregon
Are you sure the manifold is leaking or is it the EGR pipe? Both are common exhaust leak points. I've heard bad things about the MAF header. I'd search some more about those before you pull the trigger. Good luck!

:beer: Chad
 
Joined
Nov 11, 2008
Messages
1,587
Location
Anniston, AL
Only thing i'm going on is the noise and a bunch of carbon buildup near the 6th cylinder on the manifold.

Any info on the intermediate dash lights and how to operate the headlamp washers?
 
Joined
Nov 11, 2008
Messages
1,587
Location
Anniston, AL
Finally got around to swapping the spark plugs/wires/cap/rotor and damn this thing has at least 30 more horse power. I guess 28 years and 155k of providing spark is to much.

78453ba0.jpg

4658b430.jpg

1b8b3202.jpg


Is this the factory ac setup? I've only noticed a few 60's that look like mine, mostly southern cruisers.
200b9e8a.jpg


IPF H4's
20da8391.jpg

38f4f838.jpg


Cheap alpine head unit, and the super sweet realistic visual eq.
0f0c9186.jpg
 

klinetime574

TLCA #27404
SILVER Star
Joined
Jul 23, 2006
Messages
5,739
Location
Chicagoland, IL
My 1984 has the A/C under the Alternator.

That looks completely different than mine. Which I know is original. Any markings on the compressor? Maybe a GM unit?
 

Users who are viewing this thread

Top Bottom