my 74 will not start...:-(

Discussion in '40- & 55-Series Tech' started by Razor, Nov 7, 2005.

  1. Razor

    Razor

    Messages:
    911
    Likes Received:
    6
    Joined:
    Sep 27, 2003
    Location:
    Berthoud Colorado
    I know the started is on the way out, but I want to start it up to put it back in the garage this evening.....click click zzztttt, nothing...no lights or power anywhere......few minutes, the lights would come onl, try starting it and zzzzzt.....nothing no lights or power..

    Sounds like a loose batt cable or something, nope...all new under there.

    Any idea's...short in wirring somewhere..?

    Bumming out !


    Note: the started has been clicking before it kicks in and works since I have owned the cruiser.
     
  2. projektdotnet

    projektdotnet

    Messages:
    1,839
    Likes Received:
    0
    Joined:
    Sep 26, 2005
    Location:
    Port Orchard, WA
    if anyone you know has a starter for it you could try ask them. my friend's 86 merc did the same thing...starter=toasted. tap on it with a hammer too maybe. Also on all the ignition and starter wiring check for bare wires. if any are found wrap with electrical tape immediately.
    -Trash
     
  3. HawkDriver

    HawkDriver

    Messages:
    3,250
    Media:
    64
    Albums:
    5
    Likes Received:
    32
    Joined:
    Feb 1, 2002
    Location:
    No. Ogden, Utah
    Have a meter to check batt voltage? Starter clicking is usually due to low battery voltage. If that checks out you could try jumping the starter posts with a screwdriver (have the key on and in Neutral).

    Hard to diagnose by reading. Did you say it was a new battery?
     
  4. trekker

    trekker

    Messages:
    950
    Likes Received:
    1
    Joined:
    Sep 10, 2004
    Location:
    coastal empire
    Come on razor. Get jiggy and get out there and start the stupid thing! :bounce: :bounce2: Sounds like something let trick kal.

    Check yer batt. Charge it up.
    Jumper it. Starts... battery bad or low.

    Got a battery charger? Get yerself one.
     
  5. Razor

    Razor

    Messages:
    911
    Likes Received:
    6
    Joined:
    Sep 27, 2003
    Location:
    Berthoud Colorado
    Brand new napa batt is frickin toast....

    I don't know why I dick around with napa junk....getting on optima in the morning.....hell, 2 of the bastards...winch in line.

    I was out night wheeling lastnight....good thing it funked in my driveway, I have a feeling there is a short somewhere that drianed the batt.
     
  6. GetsUThere

    GetsUThere

    Messages:
    253
    Likes Received:
    3
    Joined:
    Apr 30, 2005
    Location:
    Down South
    If you've checked the terminals at the battery and for good contact between the battery ground and frame and frame/block cable, I'd guess the battery? When you say no lights you're not seeing anything lighting up on the dash?

    edit: hmm too slow typing that up apparently
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.