Location of O2 sensor for P0031 code, and any pertient info for rep0lacement please.

Content may include affiliate links. Please see terms for details.

Joined
Nov 14, 2017
Messages
117
Location
Florida
Got a cel, code P0031…O2 sensor. The VSC TRAC and VSC lights come on, indicating that this system is OFF. WHY?
Where is this sensor located?
Is it difficult to replace?
Are there other O2 sensors that I should replace along with this one, as a preventative, or?
Do I have to have a specific O2 sensor socket to remove and install this? What size?

Any diagrams/pics would be wonderful to have.

Thank you!
 
Joined
Apr 16, 2019
Messages
2,272
Location
Colorado
What are you using to read your codes? If using Torque, go into the real time readings and look at sensor data. Upstream sensor graphing will look like a heartbeat monitor (bouncing up and down consistently) while downstream will read pretty much flat. You can see which bank is not reading consistently or isn't providing a reading. I had a marmot chew my downstream sensor wire and had a 0 reading. Fixing the wiring solved the problem right away.

There are four 02's, two on each bank. Upstream sensors are above cats and is more likely to be the issue.

Here's a helpful read for you:


02 sensor issues can trip "safe mode" which could include VSC/TRAC functionality.
 
Last edited:
Joined
Nov 14, 2017
Messages
117
Location
Florida
What are you using to read your codes? If using Torque, go into the real time readings and look at sensor data. Upstream sensor graphing will look like a heartbeat monitor (bouncing up and down consistently) while downstream will read pretty much flat. You can see which bank is not reading consistently or isn't providing a reading. I had a marmot chew my downstream sensor wire and had a 0 reading. Fixing the wiring solved the problem right away.

There are four 02's, two on each bank. Upstream sensors are above cats and is more likely to be the issue.

Here's a helpful read for you:


02 sensor issues can trip "safe mode" which could include VSC/TRAC functionality.
Thank you for your response!
Fact is, I’m under the LX now, working on getting it replaced. Just taking a break for a quick brew (Full disclosure - KBS - Imperial Stout, Burbon Barrel…12%) , then I saw the post. May even need a shot of McCallen 15 yr, 18 would be better, but all I have is 15, for now...Eph. Damn, I shold have never, ever, NEVER sold my 80 series! But then again, this one is phenomenal! Ok, the 12% must have kicked in… :)

Oh come on! You know how it is!

I’m using a ScanGauge II, it’s all I have. Went to NAPA, got a "suppose to be OEM” o2, # 1/1 bank upstream sensor, which is what I’ve read the code to be. Damn part and socket was $200 out the door, (socket - $13!) with my DAV discount! I just got the skid plate off… I will never understand why there are two different sizes of bolts! AHC is in high mode, but NOT high enough and the creeper wheels keep locking up! My neck is killing me!
How in the hades am I suppose to get the wire unclipped! LOL! This is a task for “Alibaba the magician," with small hands. I’m going in...Wish me luck bro!
 
Joined
Apr 16, 2019
Messages
2,272
Location
Colorado
Thank you for your response!
Fact is, I’m under the LX now, working on getting it replaced. Just taking a break for a quick brew (Full disclosure - KBS - Imperial Stout, Burbon Barrel…12%) , then I saw the post. May even need a shot of McCallen 15 yr, 18 would be better, but all I have is 15, for now...Eph. Damn, I shold have never, ever, NEVER sold my 80 series! But then again, this one is phenomenal! Ok, the 12% must have kicked in… :)

Oh come on! You know how it is!

I’m using a ScanGauge II, it’s all I have. Went to NAPA, got a "suppose to be OEM” o2, # 1/1 bank upstream sensor, which is what I’ve read the code to be. Damn part and socket was $200 out the door, (socket - $13!) with my DAV discount! I just got the skid plate off… I will never understand why there are two different sizes of bolts! AHC is in high mode, but NOT high enough and the creeper wheels keep locking up! My neck is killing me!
How in the hades am I suppose to get the wire unclipped! LOL! This is a task for “Alibaba the magician," with small hands. I’m going in...Wish me luck bro!

That price is highway robbery on the part even if it's Denso for the 02 but hey, they have it in stock so that's worth something! Socket seems priced about right. Keep the receipt for that part if it isn't OEM - I feel like 02 sensor threads often end with people not happy with the box store parts.

Inventing new bad words is generally how I get the harnesses unclipped 🙂
 
Last edited:
Joined
Nov 14, 2017
Messages
117
Location
Florida
That price is highway robbery on the part even if it's Denso for the 02 but hey, they have it in stock so that's worth something! Socket seems priced about right. Keep the receipt for that part if it isn't OEM - I feel like 02 sensor threads often end with people not happy with the box store parts.

Inventing new bad words is generally how I get the harnesses unclipped 🙂
Oh no, I used the same, as my wife told me over and over, “horrible and insensitive,” words I’ve been using that I learned growing up; it’s what I’m use too 😆 .
Finally got it out, no thanks to the dumb clip. Yes, Denso, from NAPA. It was all I could get my hands on, on a Sunday. The socket was not much help, cheap POS; they gave me a 7/8, said it fit. I had to get by long handle Snap 0n 22mm (22mm, not 7/8) 12 pt. box wrench to move that thing, along with some WD fish oil, but it’s done. It must be the worst one of the four. The dealer wanted what would have resulted in over $900 ($580 lbr, $284 pts, tax, shop fee) parts and labor, not to mention the logistics involved for me to shuttle the ride and go back and forth, for at least 1 day. All for one freeking 02 sensor! Man!
 

Users who are viewing this thread

Top Bottom