Leaf springs popping out of bracket? (1 Viewer)

Joined
Nov 29, 2017
Messages
12
Location
Aspen, CO
Noticed this today while I was doing some work on my rear brakes.

Apologies for the poor description (leaf springs popping out of bracket?), but I really don't know how to describe it. The picture included below should be pretty self-explanatory.

My questions are: how big of an issue is this, and what is the best method for fixing the problem here?

Any help is very much appreciated.

unnamed.jpg
 

OSS

Joined
Jun 30, 2017
Messages
2,908
Location
Oblivion
The leaf pack clamp (or whatever it's called) is there to keep the leafs aligned in a bundle. Keep an eye on it. If the top leaf doesn't get out of whack with the rest of the pack, you're fine. Does it look like an extra leaf was added to the pack? That would explain why the clamp doesn't fit any more.
 
Joined
Sep 5, 2013
Messages
155
Location
near Los Angeles
 
It looks like you can slide it rearward 2” past the end of the 3rd leaf. Hammer it back together.
Not quite.

That clamp is riveted to the 3rd from the bottom leaf and can't slide forward or backward.
Looking at the rubber isolators, it appears that the spring pack is original, no add a leaf.

As far as why it is deformed and no longer doing it's job... too many miles is my guess and time for a suspension overhaul.
And a new muffler/tailpipe too.
 

crikeymike

Exit Offroad - Dobinsons Specialist
Supporting Vendor
Joined
Jun 6, 2005
Messages
842
Location
Jacksonville, Florida
 
 
 
I think an add a leaf is responsible. You can get a generic spring pack clamp at most auto stores that would keep them in a stack.
I was going to say the same thing, like someone bent out the stock clamp after adding a leaf or modifying the pack in some way.
 
Joined
Nov 16, 2004
Messages
1,070
Location
Simpsonville,SC
 
 
 
Thats what I did when I added a leaf and it looked 110% just like that, if you look at the arc of that 90 it would br perfect with one less leaf.
I was going to say the same thing, like someone bent out the stock clamp after adding a leaf or modifying the pack in some way.
 
Joined
Nov 29, 2017
Messages
12
Location
Aspen, CO
Thanks for all the replies. I've had this cruiser for 10 years. It's possible a leaf was added, but I don't think so.

Upon further inspection, I saw that the bracket is actually cracked on the bottom side.

Ultimately, I think I just need new springs. A small lift has been on the list for a while, I'll treat this issue as a forcing function and get it done.

Thanks again.

PC
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom