late model heater linkages/springs (1 Viewer)

Joined
Sep 3, 2007
Messages
4,432
Location
Longmont, CO
 
 
I have a bit of a heater mystery going on here, any advice is appreciated.

I've got an '82 RHD heater with a three position lever - Vent, Heat, Defrost. Its got a vent flapper in the upper section of the heater and then a heat/defrost flapper in the bottom. When I got the truck, the linkage to the lower flapper was missing, such that there were only two positions that worked - Vent and, uh, "not vent".

I bought a rebuild kit for the heater, as well as what SOR said was the spring for the lower flapper:


SOR shows this image is of the 73+ heater with the three-position lever, however my heater is different - there is no place for the spring to attach on the lower flapper and my linkage arrangement is different.


I did some booty fab to replace the linkage I'm missing - its the L-shaped piece you can see in shiny black:

The original looked something more like this:


So even with my booty fab linkage in place, something is missing, I think there should be a spring or something. I can't find any loop or hole or slot for a spring to install on the lower door, however. Help!!
 
Joined
Jan 24, 2006
Messages
5,268
Location
97707
Yours in unique as it is a RHD model and uses the double arms and no lower blend door spring.

Shane
 
Joined
Sep 3, 2007
Messages
4,432
Location
Longmont, CO
 
 
I knew AATLAS would have the answer.

SO no lower spring huh? Just friction holds the door in place?
 
Joined
Jan 24, 2006
Messages
5,268
Location
97707
I knew AATLAS would have the answer.

SO no lower spring huh? Just friction holds the door in place?
The upper lever that has the "L" lot, this keeps the lower door closed when pulled into position.

Best,

Shane
 

twoturtlesracing

Slowwly but surely...
Joined
Oct 7, 2009
Messages
847
Location
Castle Rock, CO
 
 
Hey Guys!

I was putting my heater together with one of Shanes heater kits tonight and ran into a problem! Nothing with Shanes kit- but with my heater linkage. I have a '75 LHD 'Cruiser that came without any heater linkages... So, I posted up on 'Mud, and soon had my hands on a heater control lever thanks to ShelfBoy1. I thought all was right with the world... Wrong!:bang: Tonight as I was putting the heater together, I found out that the lever was to short!:crybaby: Seemed like I was missing a linkage or something... I search SOR, can't find a clear picture, but then I found this thread. It appears I have a heater for a LHD that needs the same linkages that Amaurer needed... Can anyone confirm this? And does anyone want to part with theirs or know where I could get one?

A couple of pics of the problem:​



Another shot: (Sorry for the crappy cell pic)​


The tabs on the side:​




Please help me out here fellas!:cheers:
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom