Just did knuckles: clicking sound

Joined
Jul 25, 2021
Messages
71
Location
Toronto, ON
There is a slight clicking sound and light vibration when taking my foot off the gas. Just did the knuckles and heard and felt this during the test drive? Might be wheel bearings not seated correctly? Any ideas?
 
Joined
Nov 9, 2012
Messages
12,874
Location
Olathe, KS, USA
There is a slight clicking sound and light vibration when taking my foot off the gas. Just did the knuckles and heard and felt this during the test drive? Might be wheel bearings not seated correctly? Any ideas?
Gotta ask...did you get plenty of grease in the spindle bushings when you reassembled?
 
Joined
Jul 25, 2021
Messages
71
Location
Toronto, ON
Gotta ask...did you get plenty of grease in the spindle bushings when you reassembled?
I covered the bronze part with lots of bearing grease! Just jacked up the front wheel as well and there was no play when I shake the wheel from the 12 and 6 o clock position.
 
Joined
Nov 9, 2012
Messages
12,874
Location
Olathe, KS, USA
I covered the bronze part with lots of bearing grease! Just jacked up the front wheel as well and there was no play when I shake the wheel from the 12 and 6 o clock position.
Did you do ANYTHING with the DS or u-joints while you were working on it?

Greasing?
 
Joined
Nov 9, 2012
Messages
12,874
Location
Olathe, KS, USA
yes, I spun the DS by hand while plunking the driver side long CV in. Did not grease the DS or u joint!
Did you watch your seal springs during install to make sure they didn't come out? Many of us pack the back of the seal with grease to make sure they don't pop out.
 
Joined
Nov 9, 2012
Messages
12,874
Location
Olathe, KS, USA
Also did you get the caliper bolts tight?
 
Joined
Jul 25, 2021
Messages
71
Location
Toronto, ON
Did you watch your seal springs during install to make sure they didn't come out? Many of us pack the back of the seal with grease to make sure they don't pop out.
I will double check, I do recall smothering grease on the inner seal and the big wheel bearing seal. But I’m going to tear it all down again when the TRE kit arrives.
Also did you get the caliper bolts tight?

Gona double check this one as well.

On part 2 of the drive the noise seems to only come when the driveline was unloaded or brakes applied at speeds higher than 30 mph hmmm this is killing me. I have a feeling it might be the lower knuckle bearing.
 
Joined
Nov 9, 2012
Messages
12,874
Location
Olathe, KS, USA
I will double check, I do recall smothering grease on the inner seal and the big wheel bearing seal. But I’m going to tear it all down again when the TRE kit arrives.


Gona double check this one as well.

On part 2 of the drive the noise seems to only come when the driveline was unloaded or brakes applied at speeds higher than 30 mph hmmm this is killing me. I have a feeling it might be the lower knuckle bearing.
All the torture happens on the upper knuckle bearing. The overhung load when turning tears up that one.

Could be the issue.
 

Users who are viewing this thread

Top Bottom