Intermittant stumble/ miss at idle (1 Viewer)

Joined
May 14, 2009
Messages
264
Location
Bundaberg, Queensland
Hi all,
The 80 has developed a stumble for a sec or two at idle (no smoke). When cold it starts ok and after about 10 secs when the revs start to drop, it will stumble then come good for a few secs and stumble again. never stumbles / misses for more than about 2-3 secs. It is fine to drive and when warm the idle is at around 800rpm (manual) but even when the idle is stable it sounds like it is struggling to stay there if that makes any sense whatsoever.

The plugs, wires, cap and rotor are about 4000km old and the fuel pump and relay are about 2000km old.

It has always overfuelled and missed (black smoke) for a few secs when started warm, maybe they are related? The injectors are perfect and have been tested to double the yota pressures for leakdown. Fuel pressure valve changed as was the efi coolant temp sensor.

Any ideas?
 
Joined
Oct 1, 2008
Messages
311
When you say fuel pressure valve are you referring to the fuel pressure regulator? I ask because I had a fuel delivery issue and someone in my thread suggested that when the FPR goes bad, it's often an overfuel situation...
 
Joined
May 14, 2009
Messages
264
Location
Bundaberg, Queensland
When you say fuel pressure valve are you referring to the fuel pressure regulator? I ask because I had a fuel delivery issue and someone in my thread suggested that when the FPR goes bad, it's often an overfuel situation...
yeah sorry, the reg on the front of the fuel rail.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom