Installing a Manual Oil Pressure Gauge (1 Viewer)

Ducks

SILVER Star
Joined
Apr 5, 2006
Messages
1,896
Location
Oregon
I have a major oil leak that I am trying to fix but I also have something wrong with my oil pressure. When I am idling, the oil pressure gauge is almost at the "L" on the gauge. If I rev the engine, the oil pressure goes up a bit. iron_giant thinks that there is something wrong with the idiot gauge itself so I need to install a manual gauge to check to see if there really is something wrong with my oil pressure.

So, how do I install a manual oil pressure gauge? Any suggestions?

:beer: Chad
 

Godwin

Resident Herpetologist
SILVER Star
Joined
Dec 4, 2004
Messages
5,278
Location
Alabama
I've done this at least three ways. Use a t-fitting and run the stock sending unit and an aftermarket oil gauge off the port under the oil filter. Discard the stock sending unit and plug the aftermarket oil gauge line into the sending unit port. Or drill and tap one of the large bolts that holds on the side oil cooler and mount the oil line there.
 

Pighead

Stop calling it an FJ
Joined
Aug 31, 2004
Messages
8,065
Location
Denverish
iron_giant thinks that there is something wrong with the idiot gauge itself

It's common knowledge that the stock gauges suck. A mechanical oilpressure gauge is a valuable addition to your dash. I used a T fitting from Ace hardware in the original sender location, a 3 foot 1/8th" SS line and an Autometer gauge.
 
Joined
Dec 1, 2008
Messages
189
Location
Charleston, SC
It's common knowledge that the stock gauges suck. A mechanical oilpressure gauge is a valuable addition to your dash. I used a T fitting from Ace hardware in the original sender location, a 3 foot 1/8th" SS line and an Autometer gauge.


Where can I find the original sender to T into?


My factory gauge is sitting in the middle and doesn't move
 

Granite Grinder

IH8RUST
Moderator
SILVER Star
Joined
Feb 2, 2005
Messages
3,519
Location
Falkland, BC, Canada
Changing the sender is the easiest option and they are not expensive. My new to me 62 had the oil pressure pegged to max, I changed the sender and it works fine, though I still don't trust factory gauges
 

Users who are viewing this thread

Top Bottom