Ignition on '87 FJ60

Joined
May 24, 2005
Messages
2
Hi all,

I bought an FJ60 with the Downey TBI kit installed. It ran fine untill about a week ago when all of a sudden it just wouldn't start. I have narrowed the problem down to the ignition control module, but I can't find any info on this module. It is a Select ignition system, does anyone know where I can find a new module. I have already tried the local parts stores and searched Downey. Thanks for any info.
 
Joined
May 24, 2005
Messages
2
Well I found out that O'reillys carries Select. I replaced the ignition control module, but we are still not getting any fire. Also, the fuel pump is working but we don't get any fuel through the injectors. It is cycling through the throttle body just not coming out of the injectors.
 
Joined
Feb 1, 2002
Messages
171
Location
Henderson, NV
 
 
 
 
If the injectors are not firing, it can be caused by the wrong amount of voltage to them, bad injectors, or not enough fuel pressure. Check the impedance of the injectors it should be less than 3 ohms. I am not sure how the Downey computer controls the injectors, but it should limit the amount of current to them to less than 4 amps (by pulse width modulation or by resistance). They should be getting 12 volts to them to operate.

Typical GM TBI injectors need more than 9 PSI fuel pressure to work, the normal range is 14-16 PSI. I think they can run up to 25 PSI.

If you can get to a junkyard, take some other injectors from a GM TBI unit. I took some out of a 4.1L V8 in a Caddy, a 4.5L V8 in a Caddy, and a 4.3L V6 in an Astro. I am currently using the 4.5L ones (the 4.3L ones were dead). They should all be rated around 40 lbs/hr. The injectors cost $5 each at my local j-yard, cheap insurance.
 
Top Bottom