Hydro-booster Pump Motor and ABS Control

Joined
Jan 30, 2020
Messages
102
Location
Houston TX
So I just got done with a cross country trip from Texas to Canada and developed many problems that were not there when I left on my 2004 LX with 145000 miles. But at the top of my list now is every time I brake the damn ABS code gets thrown. It still stops fine but I definitely need to start looking towards a solution the beeping is annoying. Does anyone know someone that sells rebuilt ones or kits to do it yourself?

4051DB98-77F0-4CB5-8E34-606F2694F0F9.png
 
Joined
Jul 23, 2012
Messages
701
Location
❄️☃️
 
Just fork the $2500 and get a new M/C. You can gamble on a new rebuilt motor for $400, but there are internal seals that can't be replaced. I spent over a $1000 on rebuilt motor, accumulator and other misc parts and it hasn't solved the issue of the same codes.
 
Joined
Jan 30, 2020
Messages
102
Location
Houston TX
Just fork the $2500 and get a new M/C. You can gamble on a new rebuilt motor for $400, but there are internal seals that can't be replaced. I spent over a $1000 on rebuilt motor, accumulator and other misc parts and it hasn't solved the issue of the same codes.
Jesus that sucks do a lot of people have the same problems?
 
Joined
Jan 30, 2020
Messages
102
Location
Houston TX
Normal regular occurance at 120k miles to 200k miles. It's a wear item. It's in the sticky section and you can read all about it.

Cost of 100 cruiser ownership.
Damn well I think I have almost replaced every wear item after I’m done with this.
 

Drunken Ira Hayes

GOLD Star
Joined
Jul 31, 2006
Messages
224
Location
Denver, CO.
 
 
Mine went at about 255K, I purchased the entire assembly from the local dealer and replaced it. The unit has worked flawlessly for over two years, it’s expensive but you won’t need another one for a good while. You can explore cheaper routes, but speaking from experience, the OE assembly will serve you well.
 
Top Bottom