Horn plunger install easy way

Joined
May 31, 2010
Messages
2,638
It is rare that I ever have much to contribute to this great board. So here is some info on a small job that I found a easier way to do.

I dont know if the new airbag models are the same. But on my 94, no airbag I had a terrible squeaking when turning the steering wheel on cold mornings. I lubed the horn contact and it didnt help. Somone here gave me the part number for the $6 horn contact pin. So I installed it today and am hoping it will fix the issue.

I read a really good install thread that involved removing the stearing wheel, clamshell and switch gear with some wiring. Today I found a easier way.

Basically just remove the stearing wheel and clamshell. Tilt the assembly down. Push the horn contact all the way in while you look at the steering column from the top. You will see the single green wire clipped on the back of the pin. I just grabbed it with my fishing thermostats and gently popped it off. The pin then slides right out. Lube up the new one and slid it in, keep it depressed and clip the wire back on. Done in about 5 min. No need to disassemble the switches or steering and more than that.

PS. If you touch the green wire to anything while it is unclipped the horn will go off. I didnt think about this and I am sure my neighbors didnt enjoy it very much so I am glad it went quickly.
 
Joined
May 31, 2010
Messages
2,638
Well, horn plunger was a su cess but it still squeals so I might try replacing the ring as well. It looks like that will need

(45180-60040-01) which is a little more expensive. Is I'll take some pictures next time I have it apart.​

 

jfz80

Cruisin’
Joined
Jun 5, 2005
Messages
12,660
Location
Madison NC
Plenty of posts on shooting some lube at the steering shaft bushing to quiet the squeal. Mine is left turn only and only when cold. Thanks for the reminder.
 
Joined
May 31, 2010
Messages
2,638
Plenty of posts on shooting some lube at the steering shaft bushing to quiet the squeal. Mine is left turn only and only when cold. Thanks for the reminder.
That has worked in the past but was not working this time. I tried several times.
 

Users who are viewing this thread

Top Bottom