Horn .......no work .....?? 1993/4 FZJ80

Discussion in '80-Series Tech' started by In2cruisers, Nov 2, 2005.

  1. In2cruisers

    In2cruisers

    Messages:
    5,798
    Likes Received:
    72
    Joined:
    Aug 13, 2004
    Location:
    Normandy Park Wa. ........now in San Diego Ca.
    The horn was intermitent at best before but now ....NOTHING !!! I have teken off the pillow and cleaned everything behind it. The horn/relay does work in alarm mode. "honk-on honk, honk-off" just not when pillow is pushed from drivers seat. Any ideas?



    Thanks
     
  2. TX_TLC

    TX_TLC

    Messages:
    1,480
    Likes Received:
    9
    Joined:
    Apr 29, 2003
    Location:
    Texas
    Pillow? That is interesting, I have never heard it called that...

    Well having just dismantled the entire steering column on my '94 I can give you a couple things to look for. Directly behing the "pillow" there is a single wire connection. This may have come loose. The ground for the "pillow" switch is also the bolt that holds the "pillow" on to the steering wheel. This bolts in from behind on the arm of the steering wheel that points down. Make sure this is tight as my horn wouldn't work until I had tightened this bolt all the way.

    To know what is all looks like back there click here "Wiper control arm fix/Steering column write up.

    Hope this helps!
     
    Last edited: Nov 3, 2005
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.