HJ60 power steering pump leak

Joined
Sep 6, 2002
Messages
3,588
The power steering pump in my HJ60 started to leak a LOT yesterday. It is one of the ones on the bottom of the passenger side of the engine, with a remote reservoir.

Not a big deal, since I have a low mileage pump from G&S sitting on the shelf, so I will swap that in on the weekend.

But, how do I rebuild the old one? the EPC gives me a gasket kit (04446-35010) and a single bearing (90363-17004). Does anyone know if this is enough to rebuild the pump? anyone done it? or is it toast?

Further, anyone know where to get these parts? I have not called Dan yet, I admit, but are these available at any autoparts store in the white north? If so, I'll be more than happy to paypal for purchase and shipping, if anyone could pick it up.

Finally, how hard is it to swap a new box in? I have a rebuilt one on the shelf, and somehow it seems like a good idea to do this when the pump is already off and the system empty.

thanks!

jan
 
Joined
Jul 22, 2003
Messages
18,901
Location
Perth Western Australia
The power steering pump in my HJ60 started to leak a LOT yesterday. It is one of the ones on the bottom of the passenger side of the engine, with a remote reservoir.

Not a big deal, since I have a low mileage pump from G&S sitting on the shelf, so I will swap that in on the weekend.

But, how do I rebuild the old one? the EPC gives me a gasket kit (04446-35010) and a single bearing (90363-17004). Does anyone know if this is enough to rebuild the pump? anyone done it? or is it toast?

Further, anyone know where to get these parts? I have not called Dan yet, I admit, but are these available at any autoparts store in the white north? If so, I'll be more than happy to paypal for purchase and shipping, if anyone could pick it up.

Finally, how hard is it to swap a new box in? I have a rebuilt one on the shelf, and somehow it seems like a good idea to do this when the pump is already off and the system empty.

thanks!

jan
Im not too sure how the HJ60 pump works but the other pumps have vanes which can be replaced.
Pump shop told me worn vanes are the main reason for low pressure.
The shop I went to could bench test pumps to see what pressure it could generate. It saves stripping them down;)
The 1HZ pumps have a seal on the main shaft that wears a groove into it and if they cant machine it out,will need replacing.
Not sure how much will be relevant to your pump
 
Joined
Apr 30, 2005
Messages
1,660
Location
N.Q. australia
If the pump was working ok prior to the leak you just may need seals otherwise best strip it down and inspect the pump.:cheers:
Scan10165.jpg
 
Joined
Sep 6, 2002
Messages
3,588
If the pump was working ok prior to the leak you just may need seals otherwise best strip it down and inspect the pump.:cheers:

yes, I'll do that.
It was working ok, but growled terribly when even remotely cold (which means alaughable +10C in San Diego).
I suspected it was on the way out, that's why I already have a new unit. anyway, it'll be hard to get parts here in the US.
cheers,
J
 
Joined
Jul 22, 2003
Messages
18,901
Location
Perth Western Australia
yes, I'll do that.
It was working ok, but growled terribly when even remotely cold (which means alaughable +10C in San Diego).
I suspected it was on the way out, that's why I already have a new unit. anyway, it'll be hard to get parts here in the US.
cheers,
J

Good old pump shop told me to use some power steering reconditioner if they get hydraulic groan,it will cure the groan in 50% of all cases by removing the glazing.
 
Joined
Oct 10, 2006
Messages
232
Location
Timaru, South Canterbury, New Zealand
My HJ60 had a loud groan in the power steering pump, turned out to be a partially blocked strainer gauze in the reservoir causing it to starve for fluid! I removed the strainer, and it was fixed;) Could be worth a shot:grinpimp: :cheers:
 
Joined
Sep 6, 2002
Messages
3,588
My HJ60 had a loud groan in the power steering pump, turned out to be a partially blocked strainer gauze in the reservoir causing it to starve for fluid! I removed the strainer, and it was fixed;) Could be worth a shot:grinpimp: :cheers:

I tried that a while ago, and cleaned out the filter/strainer. it helped a little, but not too much.
thanks
j
 
Joined
Oct 30, 2004
Messages
1,171
Location
Winnipeg,Manitoba,Canada.
Hi,
l have never rebuilt a 2H p/s pump,also have never seen one go,l work on a lot of HJs,if the pump is leaking oil,just take the pulley off and change the shaft seal,as l have change a few shaft seals on the 3B p/s pump.
Simon
Winnipeg
 

Users who are viewing this thread

Top Bottom