HJ60 feels like brakes are dragging.. but after driving nothing seems overly hot?

B

BNEBOY

Joined
Jul 2, 2015
Messages
35
Location
Brisbane QLD
Hi all, long time lurker - thanks for all the advice gained so far much appreciated
So the 60 seems to be having drive issues which I thought were the brakes as on start up (and now continually) it feels like it is driving with the handbrake on
It brakes fine when needed, the pedal is strong (no air in the lines) and I *had* thought that it maybe the MC given searching the previous threads on here and the manual suggest this as a starting point
Now I think maybe it isn't brake related as I drove it 10 kilometers (6 miles in freedom units) and after running my hands around the calipers/ drums and even outside on the hubs nothing was hot?
Engine is running fine, idles perfectly and produces about as much power as a 2H can produce haha..
Even if was a wheel bearing I would think you could tell by heat alone
Initially about 4 days ago it seemed a bit 'grippy' on take-off and now it feels like fulltime handbrake
Nothing smells hot - I'm a bit lost with it to be honest and any advice would be appreciated, thanks!
 
P

pithicus

Joined
Nov 25, 2014
Messages
884
Location
Western victoria Australia
Jack up each wheel and see if they spin freely?
Both back wheels will have to be off the ground coz of the lsd for the test.
 
Last edited:
  • Like
Reactions: OSS
Freewheel

Freewheel

Joined
Dec 5, 2006
Messages
995
Location
Vancouver BC
even easier is to find a very slight incline and see if the truck rolls by itself when you put it in neutral.
 
OSS

OSS

SILVER Star
Joined
Jun 30, 2017
Messages
4,024
Location
Oblivion
If the front pads are dragging on the front discs - there’s no way you can touch the disc without burning yourself after driving fast for a while.
 
B

BNEBOY

Joined
Jul 2, 2015
Messages
35
Location
Brisbane QLD
Thanks people!
Just updating, the left rear wasn't spinning when lifted
The state of affairs was not great - crap all the way through it from the busted seals.
Replaced all the hub seals/brake pads and will do the right hand side tomorrow because 50% ran out of time and 50% got the s***s and started drinking beer instead
Tomorrow will tell I guess.
Cheers
 
B

BNEBOY

Joined
Jul 2, 2015
Messages
35
Location
Brisbane QLD
Well it looks like the culprit in this case was the hub seals (not the MC as initially suspected)
Changed all seal/brakes and brake fluid and it is wheeling freely again
Nice to have a win :)
 

Similar threads

Users who are viewing this thread

Top Bottom