high revving at idle or neutral

Joined
Oct 17, 2006
Messages
76
Location
Detroit
I have a 1996 LC, 170K miles. Today I noticed that when i shift into park after driving for a while, the idle speed reaches 1600 rpm.

Last week, the idle speed was about 800 rpm.

Has anyone experienced this type of behaviour? I first noticed this a few weeks ago but it went away.

I am not overheating, battery voltage is ok.

Any ideas?
 
Joined
Nov 5, 2006
Messages
108
Location
Anchorage, 10 mins. from Alaska
throttle cable sticking?

I'm having the same problem once the engine (& engine compartment) get warm. I found it was my throttle cable sticking.

I can use my toe to lift up on the bottom of the throttle pedal and RPM drops some. I easily disconnected the throttle cable from the throttle body on top of the motor and RPM's came right down. Finally, with the cable reconnected, if I touched the throttle cable just a little bit, RPMs would back rise and stay. The cable itself has lost most of it's plastic protective covering and is a bit corroded.

So I ordered a new cable and am waiting to install it. Careful ordering the part with your dealer. Make sure the parts person finds the cable that is on the same diagram as the throttle pedal. Even though mine is a '96, we had to go back to '93 to find the right cable (the electronic parts catalog was just messed up).

Maybe this is your problem too?
 
Joined
Jan 12, 2006
Messages
1,109
Location
St. Louis, MO
Do a search and you will find several of us have had this problem. Almost certainly the throttle body cable. Cruiserdan will know exactly what part(s) you need and get you the best price.

Good luck!
 

Users who are viewing this thread

Top Bottom