Help: Tapping Sound

Joined
Mar 8, 2006
Messages
193
I have a fairly loud tapping sound coming from the front of my engine. Loud at initial start, but gets a bit quieter as the engine warms up.

I tried to hear where the sound is coming from, it seems to be located tword the front of the engine, aroudn the smog pump or steering box, but I have not really looked hard yet.

Ideas on what it could be? Anybody have a smog pump make a tapping sound? It sounds like a loud valve tap, but its located in the front.

I plan on looking at it this weekend.

PP
 

REKCUT

SILVER Star
Joined
Jan 5, 2005
Messages
4,878
Location
Rogersville, Mo.
You can take a long screw driver and hold it to your ear and place the metal end on different parts of the truck and it will work as a stethoscope. You need to narrow down the possibilities.
 
Joined
Jul 5, 2005
Messages
1,486
Location
Ames, IA
Funny you should post this question. Last night a loud tapping sound started coming from the front of my engine. I left it running and opened the hood to investigate. sounded like it was coming from the power steering or smog pump. about ten seconds later the smog pump seized. :eek:
 
Joined
Mar 8, 2006
Messages
193
Funny you should post this question. Last night a loud tapping sound started coming from the front of my engine. I left it running and opened the hood to investigate. sounded like it was coming from the power steering or smog pump. about ten seconds later the smog pump seized. :eek:

I am willing to bet that is what it is on mine too. I plan on looking this weeking using some of the tips I have learned.

Good luck.

PP
 
Joined
Jul 5, 2005
Messages
1,486
Location
Ames, IA
I am willing to bet that is what it is on mine too. I plan on looking this weeking using some of the tips I have learned.

Good luck.

PP

I would be hesitant to drive it if you think it's the pump. You don't want that thing to seize while you're on the road. I lucked out and it let go while I was parked and idling. If it's making noise, it's going to fail soon.
 
Joined
Mar 8, 2006
Messages
193
I hear you. Its parked until this weekend when I can diagnose the problem, but I predict a smog pump replacement in my future
 
Joined
Jan 7, 2006
Messages
39
Location
Missoula MT
Be wary of the SOR smog pump eliminator pulley. Mine had only 600 miles on it before it failed. The belts were tightened properly but the culprit was a bering that was not pressed in correctly. It did not take long to eat away at the aluminum shaft. Mine is at a machine shop getting the aluminum shaft cut off and replaced with a steel shaft. I am sure this is a better way to go. I have never been a fan of aluminum when in contact with steel, the steel always wins.
 

Users who are viewing this thread

Top Bottom