Heater Core Ill

Joined
Jul 30, 2003
Messages
109
the heater core in my 74 fj40 gets super hot (sounds right) on the bottome for the lower vents but the top of the core never gets hot - I can place my hand right on it. It there and air bubble or some junk stuck? New cruiser to me so I do not know how long it has been like this. Any ideas on diagnostics / solutions? I was going to isolate the core and use radiator flush on it / maybe take a hose and flood it out. Any other thoughts / plans? Thanks
 
Joined
Jan 22, 2003
Messages
8,118
Location
Kansastitty
With the exception of leaks, EVERY problem I've ever had with heatercores not working properly has been DIRT, either scale, rust and crap inside, or dog hair, cottonwood seeds, leaves in the fins on the outside. The "bubbles" tend to work themselves out with repeated warming and coolong cycles.
Degnol :)
 
Joined
Apr 1, 2003
Messages
186
Location
Rosendale, NY
I believe that the upper vents only blow fresh air and heat is only supposed to come out the bottom (heater) and defroster....or a I all cold on this?
 
Joined
Jan 22, 2003
Messages
8,118
Location
Kansastitty
Paul is right, the air, either recirculated or fresh comes in the side of the top of the box and the heatercore is about halfway down and horizontal, so only hot on the bottom half of box. If blowing hot there I wouldn't do anything.
READ the post, Ed :doh
GL
Ed Long
 
Joined
Jul 30, 2003
Messages
109
Ok then - as usual - thanks agin to all. The mighty 74 is not as ill as I thought with cool air only blowing out of the top and hot out of the bottom. With that said - is there an aftermarket core that will heat on both top and bottom? Just though I'd ask. Aloha
 

Users who are viewing this thread

Top Bottom