Glow Plug Light Doesn't Work

Joined
Oct 7, 2006
Messages
781
Location
Warragul, Victoria, Australia
G'day Guys,

I have a 1986 60 series with the 12ht motor. The glow-plug light on the dash board doesn't come on and then to turn off to signal that the motor is right to turn over (I sort of hold the key in the semi-on position for about 5 seconds or so). I've had the truck for about 12 months and in that time it has never worked.

Any suggestions?

Cheers,

Ben
 
Joined
Aug 13, 2004
Messages
5,817
Location
Normandy Park Wa. ........now in San Diego Ca.
G'day Guys,

I have a 1986 60 series with the 12ht motor. The glow-plug light on the dash board doesn't come on and then to turn off to signal that the motor is right to turn over (I sort of hold the key in the semi-on position for about 5 seconds or so). I've had the truck for about 12 months and in that time it has never worked.

Any suggestions?

Cheers,

Ben

Check the fuse, bulb..........you should hear a "click" if its working anyway
 
Joined
Sep 5, 2006
Messages
649
Location
Koksilah, Vancouver Island, BC
You won't see the light unless it's quite cold out... like hovering around 0C or lower (I don't recall the glow curve for the 12HT based on outside temps) and then it will only be on for maybe a second or so (longer if below 0C).

It it runs fine, don't sweat it. The volt gauge also offers a clue to when the glow screen is in operation. The glow light is really just your indication that it's ready to crank over... not whether the system is glowing or not.
 

David*BJ70

Looking forward to reach the end of the world
Joined
Jan 13, 2004
Messages
1,993
Location
Montréal, Canada
Check the fuse, bulb..........you should hear a "click" if its working anyway

X2. I like to see my light go ON... but I always start the truck after the "click". I don't care about the light for starting the truck.
 

Users who are viewing this thread

Top Bottom