Builds George - 1983 Pickup SR5 Long Bed

Joined
Mar 25, 2017
Messages
576
Location
SLC, UT
And if you have a keen eye, you'll spot the new front mud flaps in the last picture.

I picked these up on Fleabay, and were pretty rough. Wayyy overpriced.

IMG-8929-Original.jpg


But they're here, and have no severe tears in them. So I figured they were worth it. Maybe?

IMG-8935-Original.jpg


Because they have overspray on them, they didn't clean up as well using my usual tactic. So after doing all of that, I gave them a light coating of raptor liner, and I'm super happy with the end result! We'll see how they hold up, but so far I call it a win!

IMG-8936-Original.jpg


And lastly, since we brought George home, there has been a massive exhaust leak under the hood. The exhaust stud closest to the firewall was gone. And after looking into it, and the history these motors have with shearing off, or pulling out the threads in that exact stud, I decided it would be an issue I dealt with when I eventually pull the head for the timing chain guides. The tech who helped me with the brakes couldn't help himself, and got looking in that hole with his bore scope. Turns out, the threads were still there! He cleaned them up, found a bolt that matched the thread pitch, and George is quiet as a churchmouse finally! The headaches caused by the exhaust fumes will not be missed. 😅
 
Joined
Mar 25, 2017
Messages
576
Location
SLC, UT
It's about time for a George update! Been a wild year with this old truck. Where to begin?

First off, George got to take his first trip on a tow truck a few months ago lol. Igniter died. I threw a fuel pump, coil, and fuel filter at it on the side of the road. Nada. Amazon Igniter is doing the trick - for now. I can imagine this low quality igniter won't last long.

I also replaced the clutch master and slave cylinder last week. It was dumping fluid, and the pedal was catching when depressing. Nice and smooth now. One less leak. ;)
 
Joined
Mar 25, 2017
Messages
576
Location
SLC, UT
A looong time ago, a friend sent me a mid 80's Toyota radio/cassette player, and I finally got around to installing it! I had to send it to a friend out in California to fix it, so it would play tapes again.

When I took the dash bezel out, it practically disintegrated in my hands. New ones are still available from Toyota, but they're all grey now.

IMG-1095.jpg


I got a can of interior plastic paint from Cruiser Corps, and painted it brown to match. I lost my wood grain, though. Kinda bummed about that.

IMG-1096.jpg


I touched up the chrome detailing with this pen. Looks better than the Toyota job lol.
 
Joined
Mar 25, 2017
Messages
576
Location
SLC, UT
Super pumped with it. Radio sounds fantastic, and it's so fun listening to my tapes. I have a few hundred, so it's about time I get to run them elsewhere, instead of just through my WalkMan.

IMG-1111.jpg


As you can tell, the dash is destroyed from the previous owner. Fits fine, but it isn't perfect. No rattles, and it's snug. 🤷‍♂️

The speakers are driven by a 200W Boss amp that I tucked behind the back seat.
 
Joined
Mar 25, 2017
Messages
576
Location
SLC, UT
Final cosmetic update - The passenger fender had a pretty decent dent in it, and the badge was cracked in half. Some jackwagon pulled it off, and it looked really sad.

IMG-1175.jpg


I had my dent guy that I use through the Dealership pop it out, and I replaced the badge with a decent one I got on FleaBay. Looks so much better now.

IMG-1210.jpg
 
Joined
Mar 25, 2017
Messages
576
Location
SLC, UT
Last weekend we hauled it up to Idaho, and snuck it into a car show with cars that are actually really nice lol. We threw my 83 Yamaha XT 250 in the back, and the combo got some smiles. First time George has been back to Idaho since we brought him home in 2019. I look forward to the day that I can take him up there under his own power. Who know. He'd probably survive the 100 mile trek. I just don't want to throw those dice. lol

untitled (2).jpg


untitled (6).jpg


untitled (4).jpg


untitled (17).jpg
 

clx16

SILVER Star
Joined
Oct 26, 2017
Messages
1,995
Location
Alpharetta GA
New ones are still available from Toyota, but they're all grey now.
Very nice! Wish they were available in any color for a 79. I've used that Same color SEM paint in a 100 series land cruiser. Went on surprisingly well.
 
Joined
Mar 25, 2017
Messages
576
Location
SLC, UT
Very nice! Wish they were available in any color for a 79. I've used that Same color SEM paint in a 100 series land cruiser. Went on surprisingly well.
Yeah I was bummed that it was gray, but agreed, it went on super well!
 

Users who are viewing this thread

Top Bottom