Gen V 5.3 L83 / 8L90e / Blackbox / 80series

Joined
Jul 8, 2020
Messages
6
Location
las vegas
Correct, both stock and no BCM. I kind of figured I would need a simple switch, just not sure which pin in the harness and what that signal is (ground, positive, ??)

Thanks!
That I am not 100% sure of. I have a gen5 harness guy that did my electronic side. I’ll ask him tonight and get back with you.
 
Joined
Jul 8, 2020
Messages
6
Location
las vegas
That I am not 100% sure of. I have a gen5 harness guy that did my electronic side. I’ll ask him tonight and get back with you.
So my buddy has a proprietary module that he installs to get tap shift, cruise control, tac to work, 4lo, tow/haul mode. Etc.
 
Joined
Oct 29, 2021
Messages
3
Location
Oregon
Okay, thank you. I guess I will try to get information out of a harness builder, but I doubt they will be willing to divulge info without $$ transferring hands.
 

LINUS

Waiting for the Great Pumpkin
Joined
Mar 29, 2003
Messages
6,244
Location
PNW - WA
Yes the GM ECM will pick up speed internally from the transmission. I will try and drive the Toyota tach with the GM output and try adjusting the output with HPtuners. If that doesn't work I'll use a Dakota box.

Fuel I'm using a 240lph pump in the tank and the Corvette style regulator for 58psi. Then GenV motors run fine on 58 it's just less efficient for the pump. Maybe someday I'll convert to a fuel pressure controller and a PWM pump like factory.

If you mean the Corvette fuel filter / internal FPR - just a suggestion & plumb in a FP gauge on the output (not positive what Dakota wil do/throw signals on) - I had a ‘lean run‘ -warning on a Murphy box for my LS3 after a fuel filter swap.

Yuuuup, it was fixed w/ a 2nd fresh filter swap. A simple fresh fuel filter might have burned my LS3 / def wouldn’t have been good.

:confused:
 

afraptor22

SILVER Star
Joined
Jun 23, 2014
Messages
455
Location
Stafford, VA
If you mean the Corvette fuel filter / internal FPR - just a suggestion & plumb in a FP gauge on the output (not positive what Dakota wil do/throw signals on) - I had a ‘lean run‘ -warning on a Murphy box for my LS3 after a fuel filter swap.

Yuuuup, it was fixed w/ a 2nd fresh filter swap. A simple fresh fuel filter might have burned my LS3 / def wouldn’t have been good.

:confused:
Yes the quality of the Corvette FPRs tend to vary widely! I've run a gauge and seen a 10psi swing both ways for out of the box regulators. I check it after install and if it's too far out swap it. I prefer to have something available at any auto parts store vs an aftermarket part if it fails.
 
Joined
Jan 3, 2014
Messages
340
Location
Riyadh, Saudi Arabia
How's the swap coming along?

I'm almost done with mine. Having issues trying to source a lower rad hose. I reused the factory radiator.

Did you finalize cooling?
 

thatcabledude

GOLD Star
Joined
Oct 20, 2011
Messages
5,816
Location
Walton Co, FL
How's the swap coming along?

I'm almost done with mine. Having issues trying to source a lower rad hose. I reused the factory radiator.

Did you finalize cooling?
Gates 20230. It’s a upper radiator hose for a Ford Explorer.

Pic on my swapped 80:

1637887242875.jpeg
 

afraptor22

SILVER Star
Joined
Jun 23, 2014
Messages
455
Location
Stafford, VA
Gates 20230. It’s a upper radiator hose for a Ford Explorer.

Pic on my swapped 80:

View attachment 2848273
Not sure that will work on a gen5 L83 motor unless you adapt to the older style water pump or the very new L84 style pump.

No update on the swap. We used adapters and an LS2 pump with aftermarket radiator though. That hose should work for us with the Gen3/4 style pumps.
 
Joined
Jan 3, 2014
Messages
340
Location
Riyadh, Saudi Arabia
Just wanted to let you know that my swap is complete and i've been driving it for the last 2 months. Such a nice swap when all is said and done.

The truck drives great! not happy with the mileage. My 105 came with 4:30 gears and I only have 33s under it. So it's going through the gears a lot faster.

I will be swapping in 4:10s to see how the mileage improves.

for cooling, I ended up using a GM truck hose for a newer Tahoe. The upper was a generic, not sure what car it came out of.

in regards to temps in Saudi where it's currently in the mid 40s C. I'm seeing 83c when driving normal and if I hotrod it, it gets up to 98c.

Trans never got above 140F (it reads in F because my scangauge will only display F for trans).

Reach out if you need help. If you haven't finished yours yet, you better hurry. It's a great swap!
 
Joined
Aug 18, 2014
Messages
249
I have some questions , I currently have Tors old BJ73 LS3 swapped rig . The 6l80e is giving me the shutters , so it need to be replaced . I was wondering how hard and what I would need to swap in a 8L90e ? I just read the T case should mate up since it’s running a adapter and 80 series T case. I’m assuming I would need the trans harness and control unit . Is there anything else I might run up against ? Thanks for any input .
 

torfab

Supporting Vendor
Joined
Mar 3, 2006
Messages
1,748
Location
Everett, WA
Website
www.torfab.com
The LS3 works best with the 6L80, the gen V engines are made to work with the 8 and 10 speeds better. The computer languages are basically different, meaning it’s just more efficient for them to match. There were a few Gen V engines that used the 6 speed transmissions but mainly the 6 liter in the 3/4 ton trucks. I bet your shudder problem is fluid/filter based. If you want, I can give you the contact info to the guy that built that trans you have. PM me
 

afraptor22

SILVER Star
Joined
Jun 23, 2014
Messages
455
Location
Stafford, VA
The LS3 works best with the 6L80, the gen V engines are made to work with the 8 and 10 speeds better. The computer languages are basically different, meaning it’s just more efficient for them to match. There were a few Gen V engines that used the 6 speed transmissions but mainly the 6 liter in the 3/4 ton trucks. I bet your shudder problem is fluid/filter based. If you want, I can give you the contact info to the guy that built that trans you have. PM me
What he said, I don’t think a Gen4 ECU, what you have, will talk to a Gen5 transmission. Fluid, filter or possibly the torque converter. Talk to the guy who built it and see if he updated the pump sealing rings to the 2009+ style, the older ones caused a shudder on the 1-2 shift.
 

Snicklephritz87

SILVER Star
Joined
Jan 11, 2016
Messages
131
Location
Benicia, CA
Solid build. Very interesting having a doubler as the adapter. I am looking forward to a follow up on the drive ability.
 

Users who are viewing this thread

Top Bottom