Fuel Guage not working!

  • Thread starter RyRy
  • Start date
  • Watchers 1
R

RyRy

Joined
May 20, 2003
Messages
104
Hi,

Could anyone tell me exactly how my fuel guage is wired up on my 78 Bj40 ? Its not working and i need some help to try find the problem. Cheers!

Ryan
 
tucker74

tucker74

Moderator
Joined
May 12, 2003
Messages
4,852
Location
Austin, TX
The sending unit that screws into the top of the tank (below the check cover on your tank cover) is usually the culprit. I've got a spare one in the garage I'll sell you for cheap if you're interested (check the wires on yours first). It has a plug that is connected and a ground to one of the six bolts arount the top. Follow the wire down towards the drivers side and back to where the fuel lines go through the floor as well - could have gotten pinched under the cover.

Tucker
 
Greg H.

Greg H.

Joined
Jan 29, 2008
Messages
86
The sending unit that screws into the top of the tank (below the check cover on your tank cover) is usually the culprit. I've got a spare one in the garage I'll sell you for cheap if you're interested (check the wires on yours first). It has a plug that is connected and a ground to one of the six bolts arount the top. Follow the wire down towards the drivers side and back to where the fuel lines go through the floor as well - could have gotten pinched under the cover.

Tucker

Are BJ60's the same way?
 

Similar threads

KZN130Alabama
Replies
5
Views
214
GTSSportCoupe
GTSSportCoupe
E
Replies
3
Views
217
mudgudgeon
mudgudgeon
4Ruster
Replies
5
Views
248
Squash
Squash

Users who are viewing this thread

Top Bottom