Fuel gauge started reading past full mark all the time

Joined
Dec 30, 2014
Messages
690
Location
Boise, Idaho
My original fuel gauge was working fine, then it started reading past the full mark all the time and won’t budge when fuel is lower. I pulled the float out and tested it - the fuel gauge goes down when I lower the float and up when I raise the float. Does anyone here have any idea what the problem could be?
I have a 1977 fuel gauge and tank set-up
thank you
 
Joined
Aug 2, 2004
Messages
5,055
Location
KC Mo
Ground fault in the wire to the gauge or bad sender. Rubber gasket on sender ? Test continuity from the sender wire to chassis. If you have continuity then prob a spot in the wire touching ground. When you removed the sender and tested it worked? When you removed it you used a jumper to the tank for ground? if all the above is true I would start with a new gasket. Test and report back. Cruiser outfitters sells the gasket. Apprx $5 or so.
 
Joined
Dec 30, 2014
Messages
690
Location
Boise, Idaho
Ground fault in the wire to the gauge or bad sender. Rubber gasket on sender ? Test continuity from the sender wire to chassis. If you have continuity then prob a spot in the wire touching ground. When you removed the sender and tested it worked? When you removed it you used a jumper to the tank for ground? if all the above is true I would start with a new gasket. Test and report back. Cruiser outfitters sells the gasket. Apprx $5 or so.
Thanks for the info. The rubber gasket is new as well as the sender and wiring.

Yes, I had the sender grounded when I tested it out of the tank.
I will test continuity today.
 

Users who are viewing this thread

Top Bottom