Front locker won't disengage and actuator question

This site may earn a commission from merchant affiliate
links, including eBay, Amazon, Skimlinks, and others.


Mar 25, 2005
Edmond, Oklahoma
Yesterday the front locker on my son's 94 wouldn't disengage after using it. Tried S turns in reverse on dirt and nothing would disengage it. Got it back home after a short drive and blew the Power Steering pressure hose as we turned into the driveway. Replaced the PS hose. Then I jacked up one side of the front and tried turning one of the tires to disengage it and still no luck.

So… I removed the actuator assembly with the front still locked. The gear on the actuator does not turn by hand. Should it not turn back and forth?
Diff Acuator Pic.jpg


  • Rebuild Actuators Diff Lock.pdf
    129.4 KB · Views: 372
If you remove the front actuator (this is my 97), the shiny part is the locking mechanism. To the left is locked, to the right is unlocked. If you lift the front, should be able to unlock it with a flat screwdriver while slowly spinning a wheel. There are instructions elsewhere on mud for using a 9V battery on the 2 terminals to move the gear on the actuator motor. If I find them I will update.
After fixing the actuator (or getting new one like I did), it must be installed with the diff locked and the gear in a certain position, again the gear is moved with the 9V battery power.

Found it:
Front factory locker issues

Lockers are expensive if you need to replace them, but Partsouq has pretty decent pricing last time I checked, part was around $350;
amayama trading not too bad either. 313 plus shipping, so likely close to $350.
Last edited:
On my 93, the worm gear had a lot of old dried up grease in the teeth. I spent a good 15 minutes with a 9 volt running the worm gear cleaning out all of the old grease and then regreased it with lithium. It was a night and day difference. I can hear it engage from in the cab now.
Mine was seized hard....took pictures of it. Dismantled it..discovered the aluminum housing had frozen to the shaft....cleaned up the offending parts...reassembled per my before better than ever...
The gear shouldn't spin free, but isn't locked to the worm-gear either. It should have spring tension (via the bi-directional spring).. this is what allows for the delay between the actuator cycling and "wait" for the splines in the diff to line up before the fork slides across and actually locks the axle.

It is hard to describe the force of the spring.. but if you take a pair of pliers and attempt to rotate it it SHOULD move.. as well as spring right back to the position it was in.
UPDATE…Still not unlocking...
Removed, separated both parts of the actuator. It was very clean with old grease. @kletzenklueffer Cleaned the worm gear and the big round gear with brake cleaner (great tip). Applied sparingly new grease to gears. Then applied dielectric grease to large gear face. Tested with a 12v battery (didn't have a 9v battery). Thanks to @Beowulf for posting a pic in #7 e-locker Worked great in both directions. Getting the electric motor brushes back in with the springs was fun. I ended up using pieces of fishing line to pull back on the copper wire to the brushes. I then cut them loose once the motor armature/rotor assembly was set into place.
@Izzyandsue, Thanks for the info. Tested the locker gear in the housing with a screwdriver and all was working properly.
Installed the actuator assembly in the locked position into the locked diff position. With both front tires off the ground, I turned the tires in different directions to unlock. It still doesn't unlock. I unfortunately do not have another helper this evening to test the operation prior to installing. The wiring harness looks great. I removed the diff lock dial switch. Does anyone know if there is a test procedure to test the three contacts on the dial? Any other ideas until I can remove the actuator and test it not bolted up? Is there a testing procedure for the wiring harness pins to unlock?
It seems you've been able to move both the rack-gear in the diff, and verify that the actuator moves under its own power

The diff lock knob in the dash should operate as follows:
three wires on four pins: blue/black (pin 4), red/black (1), black/green (2)
In the diff unlocked position, no continuity from blue/black to either red/black or black/green
in Rear locked position, continuity b/n blue/black and red/black, but NOT to black green
In front/rear locked, continuity b/n all three blue/black, red/black, black/green
The blue/black should see battery voltage when the ignition is in the ON position

If that checks out I'd install the locked actuator into the locked diff then apply voltage manually as you did earlier to verify movement just to get it out of the locked position. Verify the dash light then goes out. This should buy you time for troubleshooting.
Could the splines be twisted like the rear lockers do? I know nothing about the front lockers.
Probably not, as the locking collar is internal to the differential spider gears, not along the relatively long splined section of the axle shaft like on the rear.

Besides.. if the splines were turned he wouldn't have been able to manually unlock the diff using a screwdriver once the actuator was removed.
Tonight I removed the actuator. I cycled it to the unlock position with a battery. Re-installed and turned the dial. It locked just fine. Turned the dial back to the left and no unlock. I then unplugged the connector and applied 12v to the pins to unlock and it unlocked. Diff Lock position switch works properly. Every time I manually moved the gear to the locked or unlocked position, the diff lock light lit up accordingly. Still stumped…ECU test next? Speed sensor test? Where exactly is the speed sensor? Any other ideas. At least it is driving now and I still have a rear locker that works properly.

Users who are viewing this thread

Top Bottom