? for Transmission Gurus

Joined
Mar 28, 2005
Messages
211
Location
Cullman, Alabama
My transmission has been acting up lately. Starting out cold the 2-3 shift either doesn't happen or it takes a loooong time. after warm-up everything is normal. The fluid level is normal and the fluid was flushed and filled with new fluid about 12K miles ago using the "Rodney Flush" method. Yesterday the throttle cable going to the trans started intermittently sticking and this morning it stuck for quite some time.
I dropped the pan and things don't look good. The fluid was brown and what appears to be small pieces of clutch material are all in the bottom of the pan. There were two small washers stuck to the drain plug magnet. Anybody have any idea of where they came from? What are the chances that I can refill the fluid and get a few more short trips out of it while I round up replacement parts?
 
Last edited:
Joined
May 26, 2004
Messages
1,975
Location
Atlanta, GA
A440s last between 250,000 and 300,000 miles. If your truck is about that age and you have recently changed/flushed the fluid your Trans is likely on its last legs. I have seen new fluid kill more than one old trans shortly after a long overdo flush.

Also the fact that your "kickdown" cable is binding isn't a good sign either. It implies that something in the valve body itself is sticking. And the washers that were in the bottom of the pan look like the washers that hold the filter or valve body in place.

We offer rebuilt A440s w/ a 12 mo warranty if you are interested. But for now I would say drive it till it stops moving forward.
 

Users who are viewing this thread

Top Bottom